summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1998-01-04 00:10:33 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1998-01-04 00:10:33 +0000
commitba7b87c89c82758be86ccdebcabcdc0a5f7e0be9 (patch)
treed47e565d2c5f38bd2f8a624f33bbb5fd8c71f94e /configure.in
parentf877a6f9852f4c4ffe566dc0f77fd2f7f067a957 (diff)
downloadgcc-ba7b87c89c82758be86ccdebcabcdc0a5f7e0be9.tar.gz
* config.sub: Add mingw32 support.
* configure.in: Likewise. * config/mh-mingw32: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@17291 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 18469971a18..68d0d9dd58e 100644
--- a/configure.in
+++ b/configure.in
@@ -182,6 +182,9 @@ case "${host}" in
*-cygwin32*)
host_makefile_frag="${host_makefile_frag} config/mh-cygwin32"
;;
+ *-mingw32*)
+ host_makefile_frag="${host_makefile_frag} config/mh-mingw32"
+ ;;
*-windows*)
host_makefile_frag="${host_makefile_frag} config/mh-windows"
;;
@@ -462,6 +465,8 @@ done
case "${host}" in
i[3456]86-*-go32*)
configdirs="$configdirs dosrel" ;;
+ i[3456]86-*-mingw32*)
+ configdirs="$configdirs dosrel" ;;
*-cygwin32*)
configdirs="$configdirs dosrel" ;;
esac
@@ -479,6 +484,10 @@ case "${host}" in
i[3456]86-*-go32* | i[3456]86-*-msdosdjgpp*)
noconfigdirs="tcl tk expect dejagnu make texinfo bison patch flex byacc send-pr uudecode dejagnu diff guile perl apache inet itcl tix db sn gnuserv"
;;
+ i[3456]86-*-mingw32*)
+ # noconfigdirs="tcl tk expect dejagnu make texinfo bison patch flex byacc send-pr uudecode dejagnu diff guile perl apache inet itcl tix db sn gnuserv"
+ noconfigdirs="expect dejagnu cvs autoconf automake send-pr gprof rcs guile perl texinfo apache inet"
+ ;;
*-*-cygwin32)
noconfigdirs="expect dejagnu cvs autoconf automake bison send-pr gprof rcs guile perl texinfo apache inet"
;;
@@ -564,6 +573,17 @@ case "${target}" in
# linux has rx in libc
skipdirs="$skipdirs target-librx"
;;
+ i[3456]86-*-mingw32*)
+ target_configdirs="$target_configdirs target-mingw"
+ noconfigdirs="$noconfigdirs expect target-libgloss"
+
+ # Can't build gdb for cygwin32 if not native.
+ case "${host}" in
+ i[3456]86-*-mingw32) ;; # keep gdb tcl tk expect etc.
+ *) noconfigdirs="$noconfigdirs gdb tcl tk expect itcl tix db sn gnuserv"
+ ;;
+ esac
+ ;;
*-*-cygwin32)
target_configdirs="$target_configdirs target-winsup"
noconfigdirs="$noconfigdirs expect target-libgloss"
@@ -956,10 +976,10 @@ if [ "${shared}" = "yes" ]; then
esac
fi
-# If we are building for a cygwin32 host, then set INSTALL_PROGRAM_ARGS to
+# If we are building for a win32 host, then set INSTALL_PROGRAM_ARGS to
# -x. This will cause programs to be installed with .exe extensions.
case "${host}" in
-*-*-cygwin32*)
+*-*-cygwin32* | i[3456]86-*-mingw32)
sed -e 's/^INSTALL_PROGRAM_ARGS[ ]*=.*$/INSTALL_PROGRAM_ARGS = -x/' \
Makefile > Makefile.tem
rm -f Makefile