summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorayers <ayers@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-20 08:45:08 +0000
committerayers <ayers@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-20 08:45:08 +0000
commitf1716c6796fb047bec7d2ac210af45bb3a2f2f14 (patch)
tree2d95ca66ddf6c4f6d25ea3b3771adebe0f1b2ac0 /configure.in
parent66f39e51e417f894980cb4956bcc381433c4e3db (diff)
downloadgcc-f1716c6796fb047bec7d2ac210af45bb3a2f2f14.tar.gz
2006-06-20 David Ayers <d.ayers@inode.at>
PR bootstrap/28072 * configure.in: Add target-boehm-gc to noconfigdirs depending on whether target-libjava is being configured instead of whether the java front end is enabled. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@114808 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 6 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 6775f3c1001..21a464d5bdd 100644
--- a/configure.in
+++ b/configure.in
@@ -1324,20 +1324,15 @@ AC_ARG_ENABLE(objc-gc,
esac])
# Make sure we only build Boehm's garbage collector if required.
-case ,${enable_languages},:${enable_libgcj}:${enable_objc_gc} in
- *,objc,*:*:yes)
+case ,${enable_languages},:${enable_objc_gc} in
+ *,objc,*:yes)
# Keep target-boehm-gc if requested for Objective-C.
;;
- *,java,*:no:*)
- # Remove target-boehm-gc if libgcj has been disabled explicitly.
- noconfigdirs="$noconfigdirs target-boehm-gc"
- ;;
- *,java,*:*:*)
- # Keep target-boehm-gc by default for Java.
- ;;
*)
- # Otherwise remove target-boehm-gc.
- noconfigdirs="$noconfigdirs target-boehm-gc"
+ # Otherwise remove target-boehm-gc depending on target-libjava.
+ if echo " ${noconfigdirs} " | grep "target-libjava" >/dev/null 2>&1; then
+ noconfigdirs="$noconfigdirs target-boehm-gc"
+ fi
;;
esac