summaryrefslogtreecommitdiff
path: root/fixincludes/configure.ac
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2004-10-15 07:58:38 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2004-10-15 07:58:38 +0000
commit4f80d25b87fcbbec22e05d3894d0e6e47b2f1163 (patch)
tree0988a96569fcf89616a90abf081927a8c8328cf8 /fixincludes/configure.ac
parent38ddce4759617c496335aab7ee3a0fe17adbe569 (diff)
downloadgcc-4f80d25b87fcbbec22e05d3894d0e6e47b2f1163.tar.gz
2004-08-14 Paolo Bonzini <bonzini@gnu.org>
PR other/17991 * Makefile.in (ALLOBJ, TESTOBJ, FIXOBJ): Add fixopts.o. Update copyright year. * fixfixes.c (main): Call initialize_opts from fixopts.c. * fixincl.c (initialize): Call initialize_opts from fixopts.c, do not include code for parsing options (environment vars). (fix_with_system): Use a search path for applyfix, so that you can run the test suite with two-process fixincludes. * fixopts.c: New file. * configure.ac: Add --enable-twoprocess. Export ac_exeext to config.h. Default to --enable-twoprocess for MinGW32. * config.h.in: Regenerate. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@89087 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'fixincludes/configure.ac')
-rw-r--r--fixincludes/configure.ac32
1 files changed, 24 insertions, 8 deletions
diff --git a/fixincludes/configure.ac b/fixincludes/configure.ac
index e0058b11640..8499032db81 100644
--- a/fixincludes/configure.ac
+++ b/fixincludes/configure.ac
@@ -9,24 +9,40 @@ AC_PROG_CC
# Choose one or two-process fix methodology. Systems that cannot handle
# bi-directional pipes must use the two process method.
#
-case $host in
+AC_ARG_ENABLE([twoprocess],
+[ --enable-twoprocess Use a separate process to apply the fixes],
+[if test "x$enable_twoprocess" = yes; then
+ TARGET=twoprocess
+else
+ TARGET=oneprocess
+fi],
+[case $host in
i?86-*-msdosdjgpp* | \
+ i?86-*-mingw32* | \
*-*-beos* )
TARGET=twoprocess
- AC_DEFINE(SEPARATE_FIX_PROC, 1, [Define if testing and fixing are done by separate process])
;;
- vax-dec-bsd* )
+ * )
TARGET=oneprocess
- AC_DEFINE(exit, xexit, [Define to xexit if the host system does not support atexit])
- AC_DEFINE(atexit, xatexit, [Define to xatexit if the host system does not support atexit])
;;
+esac])
+AC_SUBST(TARGET)
- * )
- TARGET=oneprocess
+if test $TARGET = twoprocess; then
+ AC_DEFINE(SEPARATE_FIX_PROC, 1,
+ [Define if testing and fixing are done by separate process])
+fi
+
+case $host in
+ vax-dec-bsd* )
+ AC_DEFINE(exit, xexit, [Define to xexit if the host system does not support atexit])
+ AC_DEFINE(atexit, xatexit, [Define to xatexit if the host system does not support atexit])
;;
esac
-AC_SUBST(TARGET)
+
+AC_DEFINE_UNQUOTED([EXE_EXT], "$ac_exeext",
+ [Defined to the executable file extension on the host system])
# Checks for header files.
AC_HEADER_STDC