summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorjsm28 <jsm28@138bc75d-0d04-0410-961f-82ee72b054a4>2007-06-30 22:01:30 +0000
committerjsm28 <jsm28@138bc75d-0d04-0410-961f-82ee72b054a4>2007-06-30 22:01:30 +0000
commit0fd6d684a8b8fa74d463e7a9ad78f33842632aca (patch)
tree5793a0fcb7aa717563d22023f4f092e73a1c855d /gcc/configure.ac
parent727c427a619f335a6beae281731e8daa454c10c2 (diff)
downloadgcc-0fd6d684a8b8fa74d463e7a9ad78f33842632aca.tar.gz
* configure.ac: Check for .gnu_attribute on MIPS.
* configure, config.in: Regenerate. * config/mips/mips.c (mips_file_start): If supported, output attribute for floating-point ABI. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@126157 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 7a29b916637..3e0f53adbec 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2943,6 +2943,12 @@ LCF0:
gcc_cv_as_mips_no_shared, [2,16,0], [-mno-shared], [nop],,
[AC_DEFINE(HAVE_AS_NO_SHARED, 1,
[Define if the assembler understands -mno-shared.])])
+
+ gcc_GAS_CHECK_FEATURE([.gnu_attribute support],
+ gcc_cv_as_mips_gnu_attribute, [2,18,0],,
+ [.gnu_attribute 4,1],,
+ [AC_DEFINE(HAVE_AS_GNU_ATTRIBUTE, 1,
+ [Define if your assembler supports .gnu_attribute.])])
;;
esac