summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorJakub Jelinek <jakub@gcc.gnu.org>2012-01-19 11:43:54 +0100
committerJakub Jelinek <jakub@gcc.gnu.org>2012-01-19 11:43:54 +0100
commite9c9f128d7192b21c4be77422d76494aa7ddb474 (patch)
tree332a507497df8b7c686c17eba8ff17d9630b03c7 /gcc/configure.ac
parent7b4eaf7e352385b571bb75fd60eccf973b24c451 (diff)
downloadgcc-e9c9f128d7192b21c4be77422d76494aa7ddb474.tar.gz
re PR bootstrap/50237 (bootstrap comparison failure for libcpp/lex.o)
PR bootstrap/50237 * config/initfini-array.h: Guard content of the header with #ifdef HAVE_INITFINI_ARRAY. * configure.ac: Move gcc_AC_INITFINI_ARRAY much later into the file. Add initfini-array.h to tm_file here. * acinclude.m4 (gcc_AC_INITFINI_ARRAY): For non-ia64 do a linker test. * config.gcc: Don't add initfini-array.h to tm_file here. * configure: Regenerated. From-SVN: r183299
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 01e37b38b6e..d72be3c5b58 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1197,8 +1197,6 @@ fi
CFLAGS="$saved_CFLAGS"
CXXFLAGS="$saved_CXXFLAGS"
-gcc_AC_INITFINI_ARRAY
-
# mkdir takes a single argument on some systems.
gcc_AC_FUNC_MKDIR_TAKES_ONE_ARG
@@ -1271,6 +1269,11 @@ if test x"$tmake_file" = x
then tmake_file=$cpu_type/t-$cpu_type
fi
+# Support --enable-initfini-array.
+if test x$enable_initfini_array != xno; then
+ tm_file="${tm_file} initfini-array.h"
+fi
+
if test x"$dwarf2" = xyes
then tm_file="$tm_file tm-dwarf2.h"
fi
@@ -2422,6 +2425,8 @@ if test x$gcc_cv_ld_ro_rw_mix = xread-write; then
fi
AC_MSG_RESULT($gcc_cv_ld_ro_rw_mix)
+gcc_AC_INITFINI_ARRAY
+
# Check if we have .[us]leb128, and support symbol arithmetic with it.
gcc_GAS_CHECK_FEATURE([.sleb128 and .uleb128], gcc_cv_as_leb128,
[elf,2,11,0],,