summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-11 10:49:30 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-11 10:49:30 +0000
commite3ca137abdba59406f4ede603e77384dd23cc26b (patch)
tree19a33fe8fadb0d2abd82c987bd589f8c658de03c /gcc/configure.ac
parent90fab4b1390ced6e6d3d6e9c80d5566f6d0a0966 (diff)
downloadgcc-e3ca137abdba59406f4ede603e77384dd23cc26b.tar.gz
2007-01-11 Paolo Bonzini <bonzini@gnu.org>
* configure.ac (strict1_warn): Rename to strict_warn. (WERROR, --enable-werror, symlink hacks, stage1_cflags, cc_set_by_configure, quoted_cc_set_by_configure, stage_prefix_set_by_configure, quoted_stage_prefix_set_by_configure, all_boot_languages, all_stagestuff): Remove. (target_list): Remove bootstrap targets. * Makefile.in (quickstrap): Unconditionally make a synonym of all. (BOOT_LANGUAGES, STAGE1_CFLAGS, STAGE1_CHECKING, REMAKEFLAGS, FLAGS_TO_PASS, PREPEND_DOTDOT_TO_RELATIVE_PATHS, SUBDIR_FLAGS_TO_PASS, WERROR_FLAGS, STRICT2_WARN, LANG_STAGESTUFF, VOL_FILES, POSTSTAGE1_FLAGS_TO_PASS, STAGE2_FLAGS_TO_PASS, STAGEPROFILE_FLAGS_TO_PASS, STAGEFEEDBACK_FLAGS_TO_PASS, stage1_build, stage1_copy, stage2_build, stage2_copy, stageprofile_build, stageprofile_copy, stage3_build, stage3_copy, stagefeedback_build, stagefeedback_copy, stage4_build, clean_s1, clean_sw, bootstrap, bootstrap-lean, bootstrap2, bootstrap2-lean, bootstrap3, bootstrap3-lean, bootstrap4, bootstrap4-lean, unstage1, unstage2, unstage3, unstage4, unstageprofile, unstagefeedback, restage, restage2, restage3, restage4, restageprofile, restagefeedback, bubbleestrap, cleanstrap, unstrap, restrap, *compare, *compare3, *compare4, *compare-lean, *compare3-lean, *compare4-lean, stage1-start, stage1, stage2-start, stage2, stage3-start, stage3, stage4-start, stage4, stageprofile-start, stageprofile, stagefeedback-start, stagefeedback, risky-stage1, risky-stage2, risky-stage3, risky-stage4): Remove. (ORDINARY_FLAGS_TO_PASS): Rename to FLAGS_TO_PASS. (STAGECOPYSTUFF, STAGEMOVESTUFF): Consolidate into MOSTLYCLEANFILES. (mostlyclean): Adjust. (clean, distclean): Don't mention bootstrap stuff. * configure: Regenerate. * ada/config-lang.in, cp/config-lang.in, forttran/config-lang.in, java/config-lang.in, objc/config-lang.in, objcp/config-lang.in, treelang/config-lang.in (stagestuff): Remove. * doc/sourcebuild.texi (stage1, stage2, stage3, stage4, stageprofile, stagefeedback, stagestuff): Remove mention. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@120670 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac99
1 files changed, 8 insertions, 91 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index ddacafb6013..63710999684 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -349,11 +349,11 @@ AC_CACHE_CHECK(
CFLAGS="$save_CFLAGS"
])
-strict1_warn=
+strict_warn=
if test $ac_cv_prog_cc_w_no_long_long = yes \
&& test $ac_cv_prog_cc_w_no_variadic_macros = yes \
&& test $ac_cv_prog_cc_w_no_overlength_strings = yes ; then
- strict1_warn="-pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings"
+ strict_warn="-pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings"
fi
# Add -Wold-style-definition if it's accepted
@@ -368,7 +368,7 @@ AC_CACHE_CHECK(
CFLAGS="$save_CFLAGS"
])
if test $ac_cv_prog_cc_w_old_style_definition = yes ; then
- strict1_warn="${strict1_warn} -Wold-style-definition"
+ strict_warn="${strict_warn} -Wold-style-definition"
fi
# Add -Wmissing-format-attribute if it's accepted
@@ -383,7 +383,7 @@ AC_CACHE_CHECK(
CFLAGS="$save_CFLAGS"
])
if test $ac_cv_prog_cc_w_missing_format_attribute = yes ; then
- strict1_warn="${strict1_warn} -Wmissing-format-attribute"
+ strict_warn="${strict_warn} -Wmissing-format-attribute"
fi
# Enable -Werror, period.
@@ -391,11 +391,9 @@ AC_ARG_ENABLE(werror_always,
[ --enable-werror-always enable -Werror always], [],
[enable_werror_always=no])
if test x${enable_werror_always} = xyes ; then
- strict1_warn="${strict1_warn} -Werror"
- WERROR=-Werror
+ strict_warn="${strict_warn} -Werror"
fi
-
-AC_SUBST(strict1_warn)
+AC_SUBST(strict_warn)
# Get C++ compatibility warning flag, if supported.
AC_CACHE_CHECK(
@@ -423,26 +421,12 @@ if test "x$GCC" = "xyes"; then
fi
AC_SUBST(warn_cflags)
-# Enable -Werror in bootstrap stage2 and later.
+# Enable expensive internal checks
is_release=
if test x"`cat $srcdir/DEV-PHASE`" != xexperimental; then
is_release=yes
fi
-AC_ARG_ENABLE(werror,
-[ --enable-werror enable -Werror in bootstrap stage2 and later], [],
-[if test x$is_release = x ; then
- # Default to "yes" on development branches.
- enable_werror=yes
-else
- # Default to "no" on release branches.
- enable_werror=no
-fi])
-if test x$enable_werror = xyes ; then
- WERROR=-Werror
-fi
-AC_SUBST(WERROR)
-# Enable expensive internal checks
AC_ARG_ENABLE(checking,
[ --enable-checking[=LIST]
enable expensive run-time checks. With LIST,
@@ -972,19 +956,6 @@ AC_C_BIGENDIAN
# UNSORTED
# --------
-# Stage specific cflags for build.
-stage1_cflags=
-case $build in
-vax-*-*)
- if test x$GCC = xyes
- then
- stage1_cflags="-Wa,-J"
- else
- stage1_cflags="-J"
- fi
- ;;
-esac
-AC_SUBST(stage1_cflags)
# These libraries may be used by collect2.
# We may need a special search path to get them linked.
@@ -1628,25 +1599,6 @@ do
done
tmake_file="${tmake_file_}"
-# If the host doesn't support symlinks, modify CC in
-# FLAGS_TO_PASS so CC="stage1/xgcc -Bstage1/" works.
-# Otherwise, we can use "CC=$(CC)".
-rm -f symtest.tem
-case "$LN_S" in
- *-s*)
- cc_set_by_configure="\$(CC)"
- quoted_cc_set_by_configure="\$(CC)"
- stage_prefix_set_by_configure="\$(STAGE_PREFIX)"
- quoted_stage_prefix_set_by_configure="\$(STAGE_PREFIX)"
- ;;
- *)
- cc_set_by_configure="\`case '\$(CC)' in stage*) echo '\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\$(CC)';; esac\`"
- quoted_cc_set_by_configure="\\\`case '\\\$(CC)' in stage*) echo '\\\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\\\$(CC)';; esac\\\`"
- stage_prefix_set_by_configure="\`case '\$(STAGE_PREFIX)' in stage*) echo '\$(STAGE_PREFIX)' | sed -e 's|stage|../stage|g';; *) echo '\$(STAGE_PREFIX)';; esac\`"
- quoted_stage_prefix_set_by_configure="\\\`case '\\\$(STAGE_PREFIX)' in stage*) echo '\\\$(STAGE_PREFIX)' | sed -e 's|stage|../stage|g';; *) echo '\\\$(STAGE_PREFIX)';; esac\\\`"
- ;;
-esac
-
# This is a terrible hack which will go away some day.
host_cc_for_libada=${CC}
AC_SUBST(host_cc_for_libada)
@@ -3473,9 +3425,7 @@ lang_tree_files=
# These (without "all_") are set in each config-lang.in.
# `language' must be a single word so is spelled singularly.
all_languages=
-all_boot_languages=
all_compilers=
-all_stagestuff=
all_outputs='Makefile gccbug libada-mk'
# List of language makefile fragments.
all_lang_makefrags=
@@ -3526,7 +3476,6 @@ changequote([,])dnl
language=
boot_language=
compilers=
- stagestuff=
outputs=
gtfiles=
subdir_requires=
@@ -3561,12 +3510,7 @@ changequote([,])dnl
then all_lang_makefiles="$subdir/Makefile"
fi
all_languages="$all_languages $language"
- if test "x$boot_language" = xyes
- then
- all_boot_languages="$all_boot_languages $language"
- fi
all_compilers="$all_compilers $compilers"
- all_stagestuff="$all_stagestuff $stagestuff"
all_outputs="$all_outputs $outputs"
all_gtfiles="$all_gtfiles $gtfiles"
for f in $gtfiles
@@ -3601,8 +3545,7 @@ touch Make-hooks
target_list="all.cross start.encap rest.encap tags \
install-common install-man install-info dvi pdf html \
uninstall info man srcextra srcman srcinfo \
- mostlyclean clean distclean maintainer-clean \
- stage1 stage2 stage3 stage4 stageprofile stagefeedback"
+ mostlyclean clean distclean maintainer-clean"
for t in $target_list
do
@@ -3716,7 +3659,6 @@ AC_SUBST(htmldir)
# Substitute configuration variables
AC_SUBST(subdirs)
AC_SUBST(srcdir)
-AC_SUBST(all_boot_languages)
AC_SUBST(all_compilers)
AC_SUBST(all_gtfiles)
AC_SUBST(all_gtfiles_files_langs)
@@ -3725,15 +3667,12 @@ AC_SUBST(all_lang_makefrags)
AC_SUBST(all_lang_makefiles)
AC_SUBST(all_languages)
AC_SUBST(all_selected_languages)
-AC_SUBST(all_stagestuff)
AC_SUBST(build_exeext)
AC_SUBST(build_install_headers_dir)
AC_SUBST(build_xm_file_list)
AC_SUBST(build_xm_include_list)
AC_SUBST(build_xm_defines)
AC_SUBST(check_languages)
-AC_SUBST(cc_set_by_configure)
-AC_SUBST(quoted_cc_set_by_configure)
AC_SUBST(cpp_install_dir)
AC_SUBST(xmake_file)
AC_SUBST(tmake_file)
@@ -3760,8 +3699,6 @@ AC_SUBST(md_file)
AC_SUBST(objc_boehm_gc)
AC_SUBST(out_file)
AC_SUBST(out_object_file)
-AC_SUBST(stage_prefix_set_by_configure)
-AC_SUBST(quoted_stage_prefix_set_by_configure)
AC_SUBST(thread_file)
AC_SUBST(tm_file_list)
AC_SUBST(tm_include_list)
@@ -3816,26 +3753,6 @@ for d in $subdirs doc build
do
test -d $d || mkdir $d
done
-# If the host supports symlinks, point stage[1234] at ../stage[1234] so
-# bootstrapping and the installation procedure can still use
-# CC="stage1/xgcc -Bstage1/". If the host doesn't support symlinks,
-# FLAGS_TO_PASS has been modified to solve the problem there.
-# This is virtually a duplicate of what happens in configure.lang; we do
-# an extra check to make sure this only happens if ln -s can be used.
-case "$LN_S" in
- *-s*)
- for d in ${subdirs} ; do
- STARTDIR=`${PWDCMD-pwd}`
- cd $d
- for t in stage1 stage2 stage3 stage4 stageprofile stagefeedback include
- do
- rm -f $t
- $LN_S ../$t $t 2>/dev/null
- done
- cd $STARTDIR
- done
- ;;
-esac
],
[subdirs='$subdirs'])
AC_OUTPUT