summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2013-01-30 09:26:21 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2013-01-30 09:26:21 +0000
commita602740a1cd05d6e8b3610cf94f22d3e212ec425 (patch)
tree8515fd046813cc90ae619e11c467f19cbd84522d /gcc/configure.ac
parent8b40c28eb2dcd0d8bceab9ea92be02effda14309 (diff)
downloadgcc-a602740a1cd05d6e8b3610cf94f22d3e212ec425.tar.gz
Properly set progbits/nobits for Solaris/SPARC as
* configure.ac (HAVE_AS_SPARC_NOBITS): New test. * configure: Regenerate. * config.in: Regenerate. * config/sparc/sparc.c (sparc_solaris_elf_asm_named_section): Emit #nobits/#progbits if supported. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@195572 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index b471faef02f..9ae56048905 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3467,6 +3467,13 @@ case "$target" in
[AC_DEFINE(HAVE_AS_REGISTER_PSEUDO_OP, 1,
[Define if your assembler supports .register.])])
+ gcc_GAS_CHECK_FEATURE([@%:@nobits], gcc_cv_as_sparc_nobits,,,
+ [.section "nobits",#alloc,#write,#nobits
+ .section "progbits",#alloc,#write,#progbits])
+ AC_DEFINE_UNQUOTED(HAVE_AS_SPARC_NOBITS,
+ [`if test $gcc_cv_as_sparc_nobits = yes; then echo 1; else echo 0; fi`],
+ [Define to 1 if your assembler supports #nobits, 0 otherwise.])
+
gcc_GAS_CHECK_FEATURE([-relax option], gcc_cv_as_sparc_relax,,
[-relax], [.text],,
[AC_DEFINE(HAVE_AS_RELAX_OPTION, 1,