summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorjsm28 <jsm28@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-10 16:43:55 +0000
committerjsm28 <jsm28@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-10 16:43:55 +0000
commite9cef88cf96dc8e80c8caa800bdf553a1b118c79 (patch)
tree5e347c637b7d5a15816d74f4f5af51a761821a19 /gcc/configure.ac
parent5c2d2d325837421464b4bac2fae66c5f95bd49d2 (diff)
downloadgcc-e9cef88cf96dc8e80c8caa800bdf553a1b118c79.tar.gz
* configure.ac (glibc_header_dir): Set using with_build_sysroot if
defined. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@122795 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 2a0c86c0e21..ed5fb203eef 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3324,6 +3324,8 @@ AC_CACHE_CHECK(__stack_chk_fail in target C library,
if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
if test "x$with_sysroot" = x; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
+ elif test "x$with_build_sysroot" != "x"; then
+ glibc_header_dir="${with_build_sysroot}/usr/include"
elif test "x$with_sysroot" = xyes; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-root/usr/include"
else
@@ -3375,6 +3377,8 @@ case "$target" in
if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
if test "x$with_sysroot" = x; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
+ elif test "x$with_build_sysroot" != "x"; then
+ glibc_header_dir="${with_build_sysroot}/usr/include"
elif test "x$with_sysroot" = xyes; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-root/usr/include"
else