summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authoraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2004-05-02 07:48:53 +0000
committeraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2004-05-02 07:48:53 +0000
commit25bed96743143b77e92effd3d7d98e264075a0e3 (patch)
treeaf036adf42f561c0088ecc7bee94f7449d2a590f /gcc/configure.ac
parentd9b1ff5b1a6de47dab0a4da2991ff4d2196de212 (diff)
downloadgcc-25bed96743143b77e92effd3d7d98e264075a0e3.tar.gz
* configure.ac (FLEX, BISON): Only use tools from the build tree
if build equals host. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@81406 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index c5b354ad526..799f3ef1400 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -760,7 +760,7 @@ fi
# How about lex?
dnl Don't use AC_PROG_LEX; we insist on flex.
dnl LEXLIB is not useful in gcc.
-if test -f $srcdir/../flex/skel.c; then
+if test x${build} = x${host} && test -f $srcdir/../flex/skel.c; then
FLEX='$(objdir)/../flex/flex'
else
AC_CHECK_PROG(FLEX, flex, flex, ${CONFIG_SHELL-/bin/sh} ${srcdir}/../missing flex)
@@ -768,7 +768,7 @@ fi
# Bison?
# The -L switch is so bison can find its skeleton file.
-if test -f $srcdir/../bison/bison.simple; then
+if test x${build} = x${host} && test -f $srcdir/../bison/bison.simple; then
BISON='$(objdir)/../bison/bison -L $(srcdir)/../bison/'
else
AC_CHECK_PROG(BISON, bison, bison, ${CONFIG_SHELL-/bin/sh} ${srcdir}/../missing bison)