summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorkcook <kcook@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-25 00:15:21 +0000
committerkcook <kcook@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-25 00:15:21 +0000
commitcd29f3a4d1b4bf60c34c32a7f7644da7bb59c3dd (patch)
tree097dc6e513006ad71416ba39d9435f9fad417aad /gcc/configure.ac
parent1b5948cbb01d9304d98e8abe4fac76b0eeeaa90e (diff)
downloadgcc-cd29f3a4d1b4bf60c34c32a7f7644da7bb59c3dd.tar.gz
2005-05-24 Kelley Cook <kcook@gcc.gnu.org>
* configure.ac: Don't use gcc_AC_C_LONG_LONG. Check for existence of long long and __int64 before determining their size. * aclocal.m4: Delete gcc_AC_C_LONG_LONG. * configure, config.h.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@100131 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac10
1 files changed, 2 insertions, 8 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index da325274e1e..b853c142483 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -283,19 +283,13 @@ AC_SUBST(OUTPUT_OPTION)
AC_PROG_CPP
AC_C_INLINE
-gcc_AC_C_LONG_LONG
-
# sizeof(char) is 1 by definition.
AC_CHECK_SIZEOF(void *)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
-if test $ac_cv_c_long_long = yes; then
- AC_CHECK_SIZEOF(long long)
-fi
-if test $ac_cv_c___int64 = yes; then
- AC_CHECK_SIZEOF(__int64)
-fi
+AC_CHECK_TYPES([long long], [AC_CHECK_SIZEOF(long long)])
+AC_CHECK_TYPES([__int64], [AC_CHECK_SIZEOF(__int64)])
# ---------------------
# Warnings and checking