summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-02-29 20:43:45 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-02-29 20:43:45 +0000
commitd8a2ca589065059446e38342b16cafada83cc7cd (patch)
treee79089ace3b9ac3cfc886d8f00a6cd5a66a5d80d /gcc/configure.ac
parent12e37a4452db14b8670962f4b5101bc27028b3bc (diff)
downloadgcc-d8a2ca589065059446e38342b16cafada83cc7cd.tar.gz
* configure.ac: Add some comments delineating sections of code.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@78672 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index a6b43bd9de8..4e0d742c9b8 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1560,6 +1560,10 @@ case $use_collect2 in
;;
esac
+# ---------------------------
+# Assembler & linker features
+# ---------------------------
+
# Identify the assembler which will work hand-in-glove with the newly
# built GCC, so that we can examine its features. This is the assembler
# which will be driven by the driver program.
@@ -2622,6 +2626,10 @@ if test x"$gcc_cv_ld_pie" = xyes; then
fi
AC_MSG_RESULT($gcc_cv_ld_pie)
+# --------
+# UNSORTED
+# --------
+
if test x$with_sysroot = x && test x$host = x$target \
&& test "$prefix" != "/usr" && test "x$prefix" != "x$local_prefix" ; then
AC_DEFINE_UNQUOTED(PREFIX_INCLUDE_DIR, "$prefix/include",
@@ -2809,6 +2817,10 @@ else
fi
AC_SUBST(MAINT)dnl
+# --------------
+# Language hooks
+# --------------
+
# Make empty files to contain the specs and options for each language.
# Then add #include lines to for a compiler that has specs and/or options.
@@ -2925,6 +2937,10 @@ do
echo "lang.$t: $x" >> Make-hooks
done
+# --------
+# UNSORTED
+# --------
+
# Create .gdbinit.
echo "dir ." > .gdbinit