summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorspop <spop@138bc75d-0d04-0410-961f-82ee72b054a4>2015-12-16 17:27:57 +0000
committerspop <spop@138bc75d-0d04-0410-961f-82ee72b054a4>2015-12-16 17:27:57 +0000
commit7458b15a04e1236b61d82843e50d04e1acb6bc41 (patch)
tree1bd0fb9442c0902f334dea6a379612493333318f /gcc/configure.ac
parentc02e93ceebcb1aa1a073797eb4e55744be7a2c16 (diff)
downloadgcc-7458b15a04e1236b61d82843e50d04e1acb6bc41.tar.gz
update required isl version
we check for a the isl compute timeout function added in isl 0.13. That means GCC could still be configured with isl 0.13, 0.14, and 0.15. * config/isl.m4 (ISL_CHECK_VERSION): Check for isl_ctx_get_max_operations. * configure: Regenerate. gcc/ * config.in: Regenerate. * configure: Regenerate. * configure.ac: Remove checks for functions that exist in isl 0.13 or later. * graphite-isl-ast-to-gimple.c: Remove #ifdefs and code for isl 0.12. * graphite-optimize-isl.c: Same. * graphite-poly.c: Same. * graphite-sese-to-poly.c: Same. * graphite.h: Add comment for isl 0.14. * toplev.c (print_version): Print isl version. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@231706 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index a2caf298d33..9382ab21a58 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -5919,13 +5919,6 @@ if test "x${ISLLIBS}" != "x" ; then
saved_LIBS="$LIBS"
LIBS="$LIBS $ISLLIBS $GMPLIBS"
- AC_MSG_CHECKING([Checking for isl_schedule_constraints_compute_schedule])
- AC_TRY_LINK([#include <isl/schedule.h>],
- [isl_schedule_constraints_compute_schedule (NULL);],
- [ac_has_isl_schedule_constraints_compute_schedule=yes],
- [ac_has_isl_schedule_constraints_compute_schedule=no])
- AC_MSG_RESULT($ac_has_isl_schedule_constraints_compute_schedule)
-
AC_MSG_CHECKING([Checking for isl_options_set_schedule_serialize_sccs])
AC_TRY_LINK([#include <isl/schedule.h>],
[isl_options_set_schedule_serialize_sccs (NULL, 0);],
@@ -5933,29 +5926,13 @@ if test "x${ISLLIBS}" != "x" ; then
[ac_has_isl_options_set_schedule_serialize_sccs=no])
AC_MSG_RESULT($ac_has_isl_options_set_schedule_serialize_sccs)
- AC_MSG_CHECKING([Checking for isl_ctx_get_max_operations])
- AC_TRY_LINK([#include <isl/ctx.h>],
- [isl_ctx_get_max_operations (isl_ctx_alloc ());],
- [ac_has_isl_ctx_get_max_operations=yes],
- [ac_has_isl_ctx_get_max_operations=no])
- AC_MSG_RESULT($ac_has_isl_ctx_get_max_operations)
-
LIBS="$saved_LIBS"
CXXFLAGS="$saved_CXXFLAGS"
- if test x"$ac_has_isl_schedule_constraints_compute_schedule" = x"yes"; then
- AC_DEFINE(HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE, 1,
- [Define if isl_schedule_constraints_compute_schedule exists.])
- fi
-
if test x"$ac_has_isl_options_set_schedule_serialize_sccs" = x"yes"; then
AC_DEFINE(HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS, 1,
[Define if isl_options_set_schedule_serialize_sccs exists.])
fi
- if test x"$ac_has_isl_ctx_get_max_operations" = x"yes"; then
- AC_DEFINE(HAVE_ISL_CTX_MAX_OPERATIONS, 1,
- [Define if isl_ctx_get_max_operations exists.])
- fi
fi
GCC_ENABLE_PLUGINS