summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authoruweigand <uweigand@138bc75d-0d04-0410-961f-82ee72b054a4>2016-05-27 14:50:06 +0000
committeruweigand <uweigand@138bc75d-0d04-0410-961f-82ee72b054a4>2016-05-27 14:50:06 +0000
commite4dea112e42311165254f9bb0e539aa666f24571 (patch)
treec7ad40243cba14f5211bfdd9c0443dfdef395d7f /gcc/configure.ac
parent5f89265b619f6d9ad693b4560b0d04f31b00ed6d (diff)
downloadgcc-e4dea112e42311165254f9bb0e539aa666f24571.tar.gz
* configure.ac: Treat a --with-headers option without argument
the same as the default (i.e. consult sys-include directory). * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@236825 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index ab91de6e4b1..046c94e0a9a 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2035,7 +2035,7 @@ elif test "x$TARGET_SYSTEM_ROOT" != x; then
fi
if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
- if test "x$with_headers" != x; then
+ if test "x$with_headers" != x && test "x$with_headers" != xyes; then
target_header_dir=$with_headers
elif test "x$with_sysroot" = x; then
target_header_dir="${test_exec_prefix}/${target_noncanonical}/sys-include"