summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-04-09 17:35:18 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-04-09 17:35:18 +0000
commit57587f17a68e9094852f9cc91297a76a219f7359 (patch)
treec261fb4a84ed52a472f8babc5c6fd427d4cd4a86 /gcc/configure.ac
parentdfbfdd908460fbd5b6e93f435707cf460b5aaf0e (diff)
downloadgcc-57587f17a68e9094852f9cc91297a76a219f7359.tar.gz
* configure.ac (plugin -rdynamic test): Log result.
* configure: Regenerate. * config/sol2.h (LINK_SPEC): Handle -rdynamic. (RDYNAMIC_SPEC): Define. * config/sol2-gld.h (RDYNAMIC_SPEC): Redefine. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@158173 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index abf03c5b31f..2d7823435f4 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -4449,10 +4449,13 @@ if test x"$enable_plugin" = x"yes"; then
AC_MSG_CHECKING([for -rdynamic])
${CC} ${CFLAGS} ${LDFLAGS} -rdynamic conftest.c -o conftest > /dev/null 2>&1
if $gcc_cv_objdump -T conftest | grep foobar > /dev/null; then
+ plugin_rdynamic=yes
pluginlibs="-rdynamic"
else
+ plugin_rdynamic=no
enable_plugin=no
fi
+ AC_MSG_RESULT([$plugin_rdynamic])
fi
# Check -ldl