summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2007-03-10 16:43:55 +0000
committerJoseph Myers <jsm28@gcc.gnu.org>2007-03-10 16:43:55 +0000
commitc9ecbf8693d49366eeccfe1e0c0f9da5052550d5 (patch)
tree5e347c637b7d5a15816d74f4f5af51a761821a19 /gcc/configure.ac
parent79cd820a29e05b45f5f58d9fd77917eb39b689f6 (diff)
downloadgcc-c9ecbf8693d49366eeccfe1e0c0f9da5052550d5.tar.gz
configure.ac (glibc_header_dir): Set using with_build_sysroot if defined.
* configure.ac (glibc_header_dir): Set using with_build_sysroot if defined. * configure: Regenerate. From-SVN: r122795
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 2a0c86c0e21..ed5fb203eef 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3324,6 +3324,8 @@ AC_CACHE_CHECK(__stack_chk_fail in target C library,
if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
if test "x$with_sysroot" = x; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
+ elif test "x$with_build_sysroot" != "x"; then
+ glibc_header_dir="${with_build_sysroot}/usr/include"
elif test "x$with_sysroot" = xyes; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-root/usr/include"
else
@@ -3375,6 +3377,8 @@ case "$target" in
if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
if test "x$with_sysroot" = x; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
+ elif test "x$with_build_sysroot" != "x"; then
+ glibc_header_dir="${with_build_sysroot}/usr/include"
elif test "x$with_sysroot" = xyes; then
glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-root/usr/include"
else