summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authoruros <uros@138bc75d-0d04-0410-961f-82ee72b054a4>2010-07-09 21:00:08 +0000
committeruros <uros@138bc75d-0d04-0410-961f-82ee72b054a4>2010-07-09 21:00:08 +0000
commit66d2fcdf4f5bd644d08b4ffbf8002fec73880044 (patch)
treefcc14a696030e7258a52ca756fef8fdcd498f721 /gcc/configure.ac
parent15f8c8145abd26057f028ab65809ac37e4a7b8b6 (diff)
downloadgcc-66d2fcdf4f5bd644d08b4ffbf8002fec73880044.tar.gz
* configure.ac (gcc_cv_as_ix86_rep_lock_prefix): Fix test.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@162015 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 4e529c56cc8..57aeac62468 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3328,10 +3328,9 @@ foo: nop
gcc_cv_as_ix86_rep_lock_prefix,,,
[rep movsl
lock addl %edi, (%eax,%esi)
- lock orl $0, (%esp)])
- AC_DEFINE_UNQUOTED(HAVE_AS_IX86_REP_LOCK_PREFIX,
- [`if test $gcc_cv_as_ix86_rep_lock_prefix = yes; then echo 1; else echo 0; fi`],
- [Define true if the assembler supports 'rep <insn>, lock <insn>'.])
+ lock orl $0, (%esp)],,
+ [AC_DEFINE(HAVE_AS_IX86_REP_LOCK_PREFIX, 1,
+ [Define if the assembler supports 'rep <insn>, lock <insn>'.])])
;;