summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorbothner <bothner@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-09 01:12:01 +0000
committerbothner <bothner@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-09 01:12:01 +0000
commit0acc9e9dd78a0bb16cf6e858473d140aff3a39b8 (patch)
treefbef72a40851839e12f2525a83796c5114fea93b /gcc/configure.ac
parent1859083bc02590623eaa85a5d8c9657311453d02 (diff)
downloadgcc-0acc9e9dd78a0bb16cf6e858473d140aff3a39b8.tar.gz
* configure.ac: New --enable-mapped-location sets USE_MAPPED_LOCATION.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@82809 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 71f6f0d49a0..36068563972 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -513,6 +513,15 @@ fi
AC_SUBST(valgrind_path_defines)
AC_SUBST(valgrind_command)
+AC_ARG_ENABLE(mapped-location,
+[ --enable-mapped-location location_t is fileline integer cookie],,
+enable_mapped_location=no)
+
+if test "$enable_mapped_location" = yes ; then
+ AC_DEFINE(USE_MAPPED_LOCATION, 1,
+[Define if location_t is fileline integer cookie.])
+fi
+
# Enable code coverage collection
AC_ARG_ENABLE(coverage,
[ --enable-coverage[=LEVEL]