summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1998-09-19 23:01:43 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1998-09-19 23:01:43 +0000
commit5c61dffde4155ade15ba96592de9c109114853ed (patch)
treef05aac60973502a95d5f948b92f108c0ec5d7dde /gcc/configure.in
parentf9b635ed4a8644a0514541caa771452455e933ad (diff)
downloadgcc-5c61dffde4155ade15ba96592de9c109114853ed.tar.gz
* configure.in: Disable collect2 for nextstep. Instead use
crtbegin/crtend. * configure: Rebuilt. * config/nextstep.h (STARTFILE_SPEC): Add crtbegin. (ENDFILE_SPEC): Define. (OBJECT_FORMAT_MACHO): Define. (EH_FRAME_SECTION_ASM_OP): Define. * crtstuff.c: Handle MACHO. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@22487 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index b6969e28fa3..fb9e9b1c6c5 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -899,7 +899,7 @@ changequote([,])dnl
tmake_file=i386/t-next
xmake_file=i386/x-next
extra_objs=nextstep.o
- use_collect2=yes
+ extra_parts="crtbegin.o crtend.o"
if test x$enable_threads = xyes; then
thread_file='mach'
fi
@@ -1777,8 +1777,8 @@ changequote([,])dnl
tmake_file=m68k/t-next
xmake_file=m68k/x-next
extra_objs=nextstep.o
+ extra_parts="crtbegin.o crtend.o"
extra_headers=math-68881.h
- use_collect2=yes
float_format=m68k
if test x$enable_threads = xyes; then
thread_file='mach'