summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2003-12-07 14:13:53 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2003-12-07 14:13:53 +0000
commitf514a864765f722fd85fd107b219f072cad90102 (patch)
tree42c0ab994f3287c50779a72075a1e94a70f394bf /gcc/configure.in
parent6db5e02d39f7275e320436fa2739d416e44414a4 (diff)
downloadgcc-f514a864765f722fd85fd107b219f072cad90102.tar.gz
* configure.in: Replace AC_INIT, AC_OUTPUT, AC_CANONICAL_SYSTEM
with modern equivalents. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@74392 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in12
1 files changed, 9 insertions, 3 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index fb8d022eac8..58000b2ae8f 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -26,11 +26,14 @@
# --------------------------------
AC_PREREQ(2.57)
-AC_INIT(tree.c)
+AC_INIT
+AC_CONFIG_SRCDIR(tree.c)
AC_CONFIG_HEADER(auto-host.h:config.in)
# Determine the host, build, and target systems
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+AC_CANONICAL_TARGET
# Determine the noncanonical target name, for directory use.
_GCC_TOPLEV_NONCANONICAL_TARGET
@@ -3038,7 +3041,9 @@ fi
# Create the Makefile
# and configure language subdirectories
-AC_OUTPUT($all_outputs,
+AC_CONFIG_FILES($all_outputs)
+
+AC_CONFIG_COMMANDS([default],
[
case ${CONFIG_HEADERS} in
*auto-host.h:config.in*)
@@ -3071,3 +3076,4 @@ else true ; fi
[subdirs='$subdirs'
symbolic_link='$symbolic_link'
])
+AC_OUTPUT