summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-05-01 17:45:05 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-05-01 17:45:05 +0000
commit45449d9fd611410bbe27804eaf998e4609ae150f (patch)
treed9efe798282ba0020467e2e9372c1db251ad69e0 /gcc/configure.in
parentcfbeb30526e47b5b204a016e06b2f5613135313d (diff)
downloadgcc-45449d9fd611410bbe27804eaf998e4609ae150f.tar.gz
2001-05-01 Zack Weinberg <zackw@stanford.edu>
* config.gcc: Don't default xmake_file to ${cpu_type}/x-${cpu_type}. Remove references to deleted files. (*-*-openbsd): No need to override xmake_file. (*-*-sysv4): Treat like *-*-sysv. * configure.in: Probe for ldopen in various places, and set up collect2 to be linked with them if found. Don't dink with Windows registry stuff unless $host_os is a Win32 os name. Check to see if we need -ladvapi32. * configure: Regenerate. * Makefile: Get rid of CLIB and HOST_CLIB. Substitute in COLLECT2_LIBS and link collect2 against its contents. * build-make: Get rid of HOST_CLIB. * config/a29k/x-unix, config/alpha/x-osf, config/i386/x-aix, config/i386/x-osfrose, config/m68k/x-dpx2, config/mips/x-iris3, config/mips/x-mips, config/mips/x-osfrose, config/mips/x-sony, config/mips/x-sysv, config/rs6000/x-aix31, config/rs6000/x-aix41, config/rs6000/x-rs6000: Delete. * config/i386/x-cygwin, config/m68k/t-aux, config/mips/x-iris: Don't set CLIB. 24 x-host fragments remain, 0 x-cpu, 3 top level. 2001-05-01 Zack Weinberg <zackw@stanford.edu> * aclocal.m4 (gcc_AC_C_CHAR_BIT): Correct test program. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@41732 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in26
1 files changed, 25 insertions, 1 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 2f2d2c193d4..893e2f89880 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -521,6 +521,26 @@ else
AC_CHECK_PROG(BISON, bison, bison, false)
fi
+# These libraries may be used by collect2.
+# We may need a special search path to get them linked.
+AC_CACHE_CHECK(for collect2 libraries, gcc_cv_collect2_libs,
+[save_LIBS="$LIBS"
+for libs in '' -lld -lmld '-lmld -lexc' \
+ '-L/usr/lib/cmplrs/cc2.11 -lmld' \
+ '-L/usr/lib/cmplrs/cc3.11 -lmld'
+do
+ LIBS="$libs"
+ AC_TRY_LINK_FUNC(ldopen,
+ [gcc_cv_collect2_libs="$libs"; break])
+done
+LIBS="$save_LIBS"
+test -z "$gcc_cv_collect2_libs" && gcc_cv_collect2_libs='none required'])
+case $gcc_cv_collect2_libs in
+ "none required") ;;
+ *) COLLECT2_LIBS=$gcc_cv_collect2_libs ;;
+esac
+AC_SUBST(COLLECT2_LIBS)
+
# See if the stage1 system preprocessor understands the ANSI C
# preprocessor stringification operator. (Used by symcat.h.)
AC_C_STRINGIZE
@@ -907,13 +927,15 @@ AC_ARG_ENABLE(win32-registry,
--enable-win32-registry=KEY
Use KEY instead of GCC version as the last portion
of the registry key.],,)
-
+case $host_os in
+ win32 | pe | cygwin* | mingw32* | uwin*)
AC_MSG_CHECKING(whether windows registry support is requested)
if test x$enable_win32_registry != xno; then
AC_DEFINE(ENABLE_WIN32_REGISTRY, 1,
[Define to 1 if installation paths should be looked up in Windows32
Registry. Ignored on non windows32 hosts.])
AC_MSG_RESULT(yes)
+ AC_SEARCH_LIBS(RegOpenKeyExA, advapi32)
else
AC_MSG_RESULT(no)
fi
@@ -940,6 +962,8 @@ if test x$enable_win32_registry != xno; then
[Define to be the last portion of registry key on windows hosts.])
AC_MSG_RESULT($gcc_cv_win32_registry_key)
fi
+;;
+esac
# Get an absolute path to the GCC top-level source directory
holddir=`pwd`