summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>1999-08-03 00:06:05 +0000
committerjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>1999-08-03 00:06:05 +0000
commit293be6409084e2a60316b5714823ddaaa062be16 (patch)
treebedc842f50c42392fd276bd707033cafe2684c34 /gcc/configure.in
parentb03b2fbb955506bd690110700ea293ff519f5668 (diff)
downloadgcc-293be6409084e2a60316b5714823ddaaa062be16.tar.gz
* config/libgloss.h: Add a note discouraging use with ELF.
* configure.in: Don't use libgloss.h for ELF targets. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@28425 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in17
1 files changed, 12 insertions, 5 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 86027482798..f104a092773 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -519,6 +519,13 @@ changequote([,])dnl
tm_file=${cpu_type}/${cpu_type}.h
xm_file=${cpu_type}/xm-${cpu_type}.h
+ # On a.out targets, we need to use collect2.
+ case $machine in
+ *-*-*aout*)
+ use_collect2=yes
+ ;;
+ esac
+
# Common parts for linux-gnu and openbsd systems
case $machine in
*-*-linux-gnu*)
@@ -2086,7 +2093,7 @@ changequote([,])dnl
float_format=m68k
;;
m68020-*-elf* | m68k-*-elf*)
- tm_file="m68k/m68020-elf.h libgloss.h"
+ tm_file="m68k/m68020-elf.h"
xm_file=m68k/xm-m68kv.h
tmake_file=m68k/t-m68kelf
header_files=math-68881.h
@@ -2268,7 +2275,7 @@ changequote([,])dnl
# fi
;;
mips-wrs-vxworks)
- tm_file="mips/elf.h libgloss.h mips/vxworks.h"
+ tm_file="mips/elf.h mips/vxworks.h"
tmake_file=mips/t-ecoff
gas=yes
gnu_ld=yes
@@ -2683,7 +2690,7 @@ changequote([,])dnl
tmake_file=mips/t-ecoff
;;
mipsel-*-elf*)
- tm_file="mips/elfl.h libgloss.h"
+ tm_file="mips/elfl.h"
tmake_file=mips/t-elf
;;
mips-*-elf*)
@@ -2695,7 +2702,7 @@ changequote([,])dnl
tmake_file=mips/t-elf
;;
mips64orionel-*-elf*)
- tm_file="mips/elforion.h mips/elfl64.h libgloss.h"
+ tm_file="mips/elforion.h mips/elfl64.h"
tmake_file=mips/t-elf
;;
mips64-*-elf*)
@@ -2703,7 +2710,7 @@ changequote([,])dnl
tmake_file=mips/t-elf
;;
mips64orion-*-elf*)
- tm_file="mips/elforion.h mips/elf64.h libgloss.h"
+ tm_file="mips/elforion.h mips/elf64.h"
tmake_file=mips/t-elf
;;
mips64orion-*-rtems*)