summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-12 17:38:28 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-12 17:38:28 +0000
commitf7b90398bd26af8cd5c3d3c5e99e9422f22c6fca (patch)
tree8d719bc0f8c4fd994158d37bd05224f5fcc482c1 /gcc/configure.in
parente918799b7f980edcdc23269381412e5a7bfa6294 (diff)
downloadgcc-f7b90398bd26af8cd5c3d3c5e99e9422f22c6fca.tar.gz
1999-05-12 20:22 -0400 Zack Weinberg <zack@rabi.columbia.edu>
* configure.in: Make --enable-cpp and --with-cpp-install-dir documented options. Enable the cpp driver by default. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26908 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in21
1 files changed, 16 insertions, 5 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index c4e496bfadd..5c68cb60498 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -183,6 +183,20 @@ no) ;;
*) AC_MSG_ERROR(bad value ${enableval} given for checking option) ;;
esac])
+AC_ARG_ENABLE(cpp,
+[ --disable-cpp don't provide a user-visible C preprocessor.],
+[], [enable_cpp=yes])
+
+AC_ARG_WITH(cpp_install_dir,
+[ --with-cpp-install-dir=DIR
+ install the user visible C preprocessor in DIR
+ (relative to PREFIX) as well as PREFIX/bin.],
+[if test x$withval = xyes; then
+ AC_MSG_ERROR([option --with-cpp-install-dir requires an argument])
+elif test x$withval != xno; then
+ cpp_install_dir=$withval
+fi])
+
# Use cpplib+cppmain for the preprocessor, but don't link it with the compiler.
cpp_main=cccp
AC_ARG_ENABLE(cpplib,
@@ -194,7 +208,7 @@ fi)
# Link cpplib into the compiler proper, for C/C++/ObjC.
AC_ARG_ENABLE(c-cpplib,
[ --enable-c-cpplib link cpplib directly into C and C++ compilers
- (implies --enable-cpplib).],
+ (EXPERIMENTAL) (implies --enable-cpplib).],
if test x$enable_c_cpplib != xno; then
extra_c_objs="${extra_c_objs} libcpp.a"
extra_cxx_objs="${extra_cxx_objs} ../libcpp.a"
@@ -422,9 +436,6 @@ host_xmake_file=
host_truncate_target=
host_exeext=
-# It is relative to $prefix.
-cpp_install_dir=
-
# Decode the host machine, then the target machine.
# For the host machine, we save the xm_file variable as host_xm_file;
# then we decode the target machine and forget everything else
@@ -3528,7 +3539,7 @@ then
fi
# Handle cpp installation.
-if [[ x$enable_cpp != x ]]
+if test x$enable_cpp != xno
then
tmake_file="$tmake_file t-install-cpp"
fi