summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>2000-06-14 03:06:30 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>2000-06-14 03:06:30 +0000
commit59420fa783ac122c63a0d4bc98c42ef0e62206a5 (patch)
tree53962673f5e6ee8793a3eff13379e88544c35e7f /gcc/configure.in
parentdaf887adf9c2baa722b2bb0d577308115a25b673 (diff)
downloadgcc-59420fa783ac122c63a0d4bc98c42ef0e62206a5.tar.gz
* configure.in: Use --enable-checking=misc,tree,gc by default if
no --enable-checking option is given and for --enable-checking=yes. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@34540 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 92d9983e0e4..e37984fa006 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -189,7 +189,7 @@ ac_rtl_checking=
ac_gc_checking=
ac_gc_always_collect=
case "${enableval}" in
-yes) ac_checking=1 ; ac_tree_checking=1 ; ac_rtl_checking=1 ;;
+yes) ac_checking=1 ; ac_tree_checking=1 ; ac_gc_checking=1 ;;
no) ;;
*) IFS="${IFS= }"; ac_save_IFS="$IFS" IFS="$IFS,"
set fnord $enableval; shift
@@ -207,6 +207,9 @@ no) ;;
done
;;
esac
+],
+# Enable some checks by default for development versions of GCC
+[ac_checking=1; ac_tree_checking=1; ac_gc_checking=1;])
if test x$ac_checking != x ; then
AC_DEFINE(ENABLE_CHECKING, 1,
[Define if you want more run-time sanity checks. This one gets a grab
@@ -235,7 +238,7 @@ if test x$ac_gc_always_collect != x ; then
paranoid mode, validating the entire heap and collecting garbage at
every opportunity. This is extremely expensive.])
fi
-])
+
AC_ARG_ENABLE(cpp,
[ --disable-cpp don't provide a user-visible C preprocessor.],