summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorneil <neil@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-06 07:22:01 +0000
committerneil <neil@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-06 07:22:01 +0000
commit7eda354a6f764900c1db7d8a0d30fe4c084ba074 (patch)
treec15a70516f598de133ec9104c90fc14238a59310 /gcc/configure.in
parent2eb1914f18fcab815865c3c5480445b3565631d5 (diff)
downloadgcc-7eda354a6f764900c1db7d8a0d30fe4c084ba074.tar.gz
* configure.in: Add check for lstat.
* configure, config.in: Regenerate. * cppinit.c (append_include_chain): Make empty path ".". * cpplib.c (do_line): Don't simplify #line paths. * cppfiles.c (remove_component_p): New function. (find_or_create_entry): Acknowledge stat () errors during path simplification. (handle_missing_header): Don't simplify paths. (_cpp_simplify_pathname): Don't simplify VMS paths. Return the empty path untouched. Don't leave a trailing '/'. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@41148 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index ca356f30cc3..1e5f4088964 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -547,7 +547,7 @@ dnl gcc_AC_C_ENUM_BF_UNSIGNED
AC_CHECK_FUNCS(strtoul bsearch popen \
strchr strrchr kill getrlimit setrlimit atoll atoq \
sysconf isascii gettimeofday strsignal putc_unlocked fputc_unlocked \
- fputs_unlocked getrusage iconv nl_langinfo)
+ fputs_unlocked getrusage iconv nl_langinfo lstat)
AC_CHECK_TYPE(ssize_t, int)