summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-05 04:34:24 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-05 04:34:24 +0000
commite1688c3e2cfd39905939794abac3060e2422d18f (patch)
treebbcd83b13f1ee8c2065b3819d7dd96fc78b6b62f /gcc/configure.in
parent194d4e232df38645d9f6e3477d76c99fa9857f98 (diff)
downloadgcc-e1688c3e2cfd39905939794abac3060e2422d18f.tar.gz
* config.gcc: Remove default for xm_file. Clean up local
machine type handling. Remove settings of xm_file to something that doesn't exist. In the big switch, set xm_file, don't append to it (the value before the big switch is always null). Don't force build_xm_file or host_xm_file to have a value. * configure.in: Remove default for xm_file. Do not special case $cpu/xm-$cpu.h not existing. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@41106 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in13
1 files changed, 2 insertions, 11 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 726c0a78d30..ca356f30cc3 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -642,9 +642,6 @@ then tm_file=$cpu_type/$cpu_type.h; fi
if test x"$extra_headers" = x
then extra_headers=; fi
-if test x"$xm_file" = x
-then xm_file=$cpu_type/xm-$cpu_type.h; fi
-
if test x$md_file = x
then md_file=$cpu_type/$cpu_type.md; fi
@@ -679,15 +676,13 @@ echo "Using \`$srcdir/config/$out_file' for machine-specific logic."
echo "Using \`$srcdir/config/$md_file' as machine description file."
# If any of the xm_file variables contain nonexistent files, warn
-# about them and drop them. But $cpu/xm-$cpu.h is allowed not to
-# exist, if we have nothing for it to do.
+# about them and drop them.
+
changequote(,)dnl
bx=
for x in $build_xm_file; do
if test -f $srcdir/config/$x
then bx="$bx $x"
- elif expr $x : '\([^/]*\)/xm-\1\.h' >/dev/null
- then :
else AC_MSG_WARN($srcdir/config/$x does not exist.)
fi
done
@@ -697,8 +692,6 @@ hx=
for x in $host_xm_file; do
if test -f $srcdir/config/$x
then hx="$hx $x"
- elif expr $x : '\([^/]*\)/xm-\1\.h' >/dev/null
- then :
else AC_MSG_WARN($srcdir/config/$x does not exist.)
fi
done
@@ -708,8 +701,6 @@ tx=
for x in $xm_file; do
if test -f $srcdir/config/$x
then tx="$tx $x"
- elif expr $x : '\([^/]*\)/xm-\1\.h' >/dev/null
- then :
else AC_MSG_WARN($srcdir/config/$x does not exist.)
fi
done