summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2002-01-08 19:03:20 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2002-01-08 19:03:20 +0000
commita1a7e9d5c4b55fbcac064ab702083001c2a9cd93 (patch)
treea1f592db0d3440c72c8daede62b2c3b7eee7ad28 /gcc/configure.in
parenteee3a9901f90425846f5c0e0bec39a4ee86fcc48 (diff)
downloadgcc-a1a7e9d5c4b55fbcac064ab702083001c2a9cd93.tar.gz
* Makefile.in (cs-tconfig.h): Don't depend on $(CONFIG_H) or
except.h. Remove commands to define USING_SJLJ_EXCEPTIONS. (cppinit.o): Depend on except.h. (gencheck.h, options.h, specs.h, s-gencheck, s-options, s-specs): New rules. * configure.in: Don't AC_DEFINE_UNQUOTED PACKAGE or VERSION. Don't create specs.h/options.h/gencheck.h here. Remove unnecessary variable settings from last argument of AC_OUTPUT. * config.in, configure: Regenerate. * intl.c: Hardcode package name as "gcc". * cppinit.c: Include except.h. (builtin_array): Define __USING_SJLJ_EXCEPTIONS__ when appropriate. * unwind-dw2.c, unwind-sjlj.c, config/ia64/unwind-ia64.c: Use #if(n)def __USING_SJLJ_EXCEPTIONS, not #if (!)USING_SJLJ_EXCEPTIONS. * doc/cpp.texi: Document __USING_SJLJ_EXCEPTIONS__. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@48651 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in49
1 files changed, 6 insertions, 43 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 11e66310f99..03e87a79a61 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -908,10 +908,6 @@ changequote([,])dnl
# Internationalization
PACKAGE=gcc
VERSION="$gcc_version"
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE",
- [Define to the name of the distribution.])
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION",
- [Define to the version of the distribution.])
AC_SUBST(PACKAGE)
AC_SUBST(VERSION)
@@ -2140,21 +2136,16 @@ AC_DEFINE_UNQUOTED(CONFIG_SJLJ_EXCEPTIONS, $sjlj,
lang_specs_files=
lang_options_files=
lang_tree_files=
-rm -f specs.h options.h gencheck.h
-touch specs.h options.h gencheck.h
for subdir in . $subdirs
do
if test -f $srcdir/$subdir/lang-specs.h; then
- echo "#include \"$subdir/lang-specs.h\"" >>specs.h
- lang_specs_files="$lang_specs_files $srcdir/$subdir/lang-specs.h"
+ lang_specs_files="$lang_specs_files $srcdir/$subdir/lang-specs.h"
fi
if test -f $srcdir/$subdir/lang-options.h; then
- echo "#include \"$subdir/lang-options.h\"" >>options.h
- lang_options_files="$lang_options_files $srcdir/$subdir/lang-options.h"
+ lang_options_files="$lang_options_files $srcdir/$subdir/lang-options.h"
fi
if test -f $srcdir/$subdir/$subdir-tree.def; then
- echo "#include \"$subdir/$subdir-tree.def\"" >>gencheck.h
- lang_tree_files="$lang_tree_files $srcdir/$subdir/$subdir-tree.def"
+ lang_tree_files="$lang_tree_files $srcdir/$subdir/$subdir-tree.def"
fi
done
@@ -2464,35 +2455,7 @@ if test -f intl/libintl.h; then
echo creating libintl.h
echo '#include "intl/libintl.h"' >libintl.h
fi
-],
-[
-host='${host}'
-build='${build}'
-target='${target}'
-target_alias='${target_alias}'
-srcdir='${srcdir}'
-subdirs='${subdirs}'
-symbolic_link='${symbolic_link}'
-program_transform_set='${program_transform_set}'
-program_transform_name='${program_transform_name}'
-dep_host_xmake_file='${dep_host_xmake_file}'
-host_xmake_file='${host_xmake_file}'
-dep_tmake_file='${dep_tmake_file}'
-tmake_file='${tmake_file}'
-thread_file='${thread_file}'
-gcc_config_arguments='${gcc_config_arguments}'
-gcc_version='${gcc_version}'
-gcc_version_full='${gcc_version_full}'
-gcc_version_trigger='${gcc_version_trigger}'
-local_prefix='${local_prefix}'
-build_install_headers_dir='${build_install_headers_dir}'
-build_exeext='${build_exeext}'
-host_exeext='${host_exeext}'
-out_file='${out_file}'
-gdb_needs_out_file_path='${gdb_needs_out_file_path}'
-SET_MAKE='${SET_MAKE}'
-target_list='${target_list}'
-target_overrides='${target_overrides}'
-host_overrides='${host_overrides}'
-cpp_install_dir='${cpp_install_dir}'
+],
+[subdirs='$subdirs'
+symbolic_link='$symbolic_link'
])