summaryrefslogtreecommitdiff
path: root/intl/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2003-07-08 05:55:11 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2003-07-08 05:55:11 +0000
commitc6976b580a332f8b261546e8f8bcb784a183fbf8 (patch)
tree69b1e37b7015fae738d99619fce13dfd3030dea0 /intl/configure.in
parent3685771481bbefac5d52a86aee956e6cd6c253e9 (diff)
downloadgcc-c6976b580a332f8b261546e8f8bcb784a183fbf8.tar.gz
top:
* Makefile.tpl (configure-gcc): Depend on maybe-configure-intl. * Makefile.in: Regenerate. config: * gettext.m4: Delete all former contents. (ZW_GNU_GETTEXT_SISTER_DIR): New macro. * progtest.m4: New file. gcc: * Makefile.in (top_builddir): Set to "..", not ".". (INTLLIBS, INTLDEPS): Delete. (LIBINTL, LIBINTL_DEP, LIBICONV_DEP): New variables to be substituted. (LIBDEPS): Add $(LIBICONV_DEP). (LIBS): Take out $(INTLLIBS), add $(LIBINTL) and $(LIBICONV). (INCLUDES): Replace -I../intl with @INCINTL@. ($(top_builddir)/intl/libintl.a): Delete rule. (stage2-start, stage3-start, stage4-start, stageprofile-start, stagefeedback-start): Use $$ for variable to be evaluated by shell, not make. * acconfig.h (ENABLE_NLS, HAVE_CATGETS, HAVE_GETTEXT, HAVE_LC_MESSAGES, HAVE_STPCPY): Delete. * aclocal.m4: sinclude ../config/progtest.m4. Add contents of lcmessage.m4 from gettext distro. * configure.in: Check for wchar.h and setlocale. Set LIBICONV_DEP to the empty string and substitute it. Call AM_LC_MESSAGES. Delete AC_ARG_ENABLE for --enable-nls; this is handled elsewhere. Use ZW_GNU_GETTEXT_SISTER_DIR, not CY_GNU_GETTEXT. Clear $LIBICONV if its text is included in $LIBINTL, to avoid linking it twice. * configure, config.in: Regenerate. intl: * README: Update. * Makefile.in (INSTALL, INSTALL_DATA, MKINSTALLDIRS, mkinstalldirs, gettextsrcdir, l): Delete. (COMPILE): Add $(DEFS-$@), remove $(XCFLAGS). (HEADERS): libgnuintl.h not libgnuintl.h.in. Remove os2compat.h. (SOURCES): Remove os2compat.c. (DEFS-dcigettext.o, DEFS-localealias.o, DEFS-localcharset.o, DEFS-relocatable.o): New. (all-yes): Add config.intl. (libintl.h): Use cp, not cat. (INCLUDES): Remove -I.. (TAGS, CTAGS, ID): Word wrap. (mostlyclean, distclean): Remove junk. (config.intl): New rule. * aclocal.m4: sinclude ../config/progtest.m4 instead of including it inline. * config.intl.in: New file. * configure.in: Take out unnecessary AC_CONFIG_AUX_DIR. Take out AC_DEFINEs for LOCALEDIR, LOCALE_ALIAS_PATH, LIBDIR, INSTALLDIR. Set LIBINTL_DEP and INCINTL and AC_SUBST them. Add config.intl to AC_OUTPUT. * os2compat.c, os2compat.h: Delete, unused. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@69071 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'intl/configure.in')
-rw-r--r--intl/configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/intl/configure.in b/intl/configure.in
index 45735067c04..692ff2595ae 100644
--- a/intl/configure.in
+++ b/intl/configure.in
@@ -1,19 +1,10 @@
AC_PREREQ(2.13)
AC_INIT(gettext.c)
-AC_CONFIG_AUX_DIR(..)
AC_CONFIG_HEADER(config.h)
AM_GNU_GETTEXT_VERSION(0.12.1)
AM_GNU_GETTEXT
dnl This replaces the extensive use of DEFS in the original Makefile.in.
-AC_DEFINE_UNQUOTED(LOCALEDIR, "$localedir",
-[Define to the directory holding the locale files.])
-AC_DEFINE_UNQUOTED(LOCALE_ALIAS_PATH, "$aliaspath",
-[Define to the locale alias path.])
-AC_DEFINE_UNQUOTED(LIBDIR, "$libdir",
-[Define to the library directory.])
-AC_DEFINE_UNQUOTED(INSTALLDIR, "$libdir",
-[Define to the installation directory.])
AC_DEFINE(IN_LIBINTL, 1, [Define because this is libintl.])
AC_DEFINE(IN_LIBRARY, 1, [Define because this is a library.])
AC_DEFINE(DEPENDS_ON_LIBICONV, 1, [Define because we depend on libiconv.])
@@ -24,4 +15,13 @@ AC_DEFINE(set_relocation_prefix, libintl_set_relocation_prefix,
AC_DEFINE(relocate, libintl_relocate,
[Define this entry point correctly.])
-AC_OUTPUT(Makefile)
+dnl Additional info for config.intl.
+LIBINTL_DEP= AC_SUBST(LIBINTL_DEP)
+INCINTL= AC_SUBST(INCINTL)
+
+if test $USE_INCLUDED_LIBINTL = yes; then
+ LIBINTL_DEP='${top_builddir}/intl/libintl.a'
+ INCINTL='-I${top_builddir}/intl'
+fi
+
+AC_OUTPUT(Makefile config.intl)