summaryrefslogtreecommitdiff
path: root/libchill/configure.in
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2000-05-31 23:54:07 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2000-05-31 23:54:07 +0000
commiteb998c7ddb632e4c03994b2e6e24491b5825afcb (patch)
tree86a07444501fd6b24a651f801f66bd3b3fc4a3ca /libchill/configure.in
parenta8ba17fbbb676afc03507ee5541a76f5c24fad69 (diff)
downloadgcc-eb998c7ddb632e4c03994b2e6e24491b5825afcb.tar.gz
* Makefile.in (STROBJS): Get memmove.o from configure.
* configure.in (RANLIB): Detect and substitute. (memmove): Detect and substitute. * memmove.c (memmove): Use size_t. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@34313 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libchill/configure.in')
-rw-r--r--libchill/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/libchill/configure.in b/libchill/configure.in
index b9c6a5339ab..cd08ba1f776 100644
--- a/libchill/configure.in
+++ b/libchill/configure.in
@@ -70,6 +70,11 @@ AC_PROG_CC
test "$AR" || AR=ar
AC_SUBST(AR)
+if test "$RANLIB"; then :
+ AC_SUBST(RANLIB)
+else
+ AC_PROG_RANLIB
+fi
AC_PROG_MAKE_SET
dnl Checks for libraries.
@@ -123,6 +128,10 @@ AC_CHECK_FUNC(atexit,
AC_DEFINE(onexit,on_exit),)])])
else true
fi
+AC_CHECK_FUNC(memmove,
+ MEMMOVE_O='',
+ MEMMOVE_O=memmove.o)
+AC_SUBST(MEMMOVE_O)
# We need multilib support, but only if configuring for the target.
AC_OUTPUT(Makefile,