summaryrefslogtreecommitdiff
path: root/libcpp/configure.ac
diff options
context:
space:
mode:
authoramylaar <amylaar@138bc75d-0d04-0410-961f-82ee72b054a4>2010-06-09 10:32:23 +0000
committeramylaar <amylaar@138bc75d-0d04-0410-961f-82ee72b054a4>2010-06-09 10:32:23 +0000
commit9d135bb6fd95b12a9e1a076a48cc2b4c0a5a2c2e (patch)
tree2e4596e9549c064794426f4a44005559b7d52198 /libcpp/configure.ac
parent9e0a5037e5ef6125706bad548d0d5def983abb22 (diff)
downloadgcc-9d135bb6fd95b12a9e1a076a48cc2b4c0a5a2c2e.tar.gz
PR bootstrap/44432
* configure.ac: Before using ZW_PROG_COMPILER_DEPENDENCIES for C++, check that C++ compiler works. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@160460 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libcpp/configure.ac')
-rw-r--r--libcpp/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/libcpp/configure.ac b/libcpp/configure.ac
index 9dcec239bc1..ceea29ce165 100644
--- a/libcpp/configure.ac
+++ b/libcpp/configure.ac
@@ -45,6 +45,10 @@ ZW_CREATE_DEPDIR
if test "$ENABLE_BUILD_WITH_CXX" = "no"; then
ZW_PROG_COMPILER_DEPENDENCIES([CC])
else
+AC_LANG_PUSH([C++])
+AC_COMPILE_IFELSE([[int i;]], [],
+ [AC_MSG_ERROR([C++ compiler missing or inoperational])])
+AC_LANG_POP([C++])
ZW_PROG_COMPILER_DEPENDENCIES([CXX])
fi