summaryrefslogtreecommitdiff
path: root/libcpp/configure.ac
diff options
context:
space:
mode:
authorrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2014-05-26 08:19:02 +0000
committerrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2014-05-26 08:19:02 +0000
commit1c8ad86a7b27987d2d1d620c665bfb6a28d5325d (patch)
treee28b8ab33b2de7eaa12479bdb8dfb1291a7f26d0 /libcpp/configure.ac
parenta142dffd4a046460b3e2d05481b93d5263aef6a5 (diff)
downloadgcc-1c8ad86a7b27987d2d1d620c665bfb6a28d5325d.tar.gz
2014-05-26 Richard Biener <rguenther@suse.de>
libcpp/ * configure.ac: Remove long long and __int64 type checks, add check for uint64_t and fail if that wasn't found. * include/cpplib.h (cpp_num_part): Use uint64_t. * config.in: Regenerate. * configure: Likewise. gcc/ * configure.ac: Drop __int64 type check. Insist that we found uint64_t and int64_t. * hwint.h (HOST_BITS_PER___INT64): Remove. (HOST_BITS_PER_WIDE_INT): Define to 64 and remove __int64 case. (HOST_WIDE_INT_PRINT_*): Remove 32bit case. (HOST_WIDEST_INT*): Define to HOST_WIDE_INT*. (HOST_WIDEST_FAST_INT): Remove __int64 case. * vmsdbg.h (struct _DST_SRC_COMMAND): Use int64_t for dst_q_src_df_rms_cdt. * configure: Regenerate. * config.in: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@210928 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libcpp/configure.ac')
-rw-r--r--libcpp/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/libcpp/configure.ac b/libcpp/configure.ac
index 93616add3bd..5f008a4a67f 100644
--- a/libcpp/configure.ac
+++ b/libcpp/configure.ac
@@ -64,8 +64,10 @@ AC_TYPE_SIZE_T
AC_TYPE_SSIZE_T
AC_TYPE_UINTPTR_T
AC_CHECK_TYPE(ptrdiff_t, int)
-AC_CHECK_TYPES([long long], [AC_CHECK_SIZEOF(long long)])
-AC_CHECK_TYPES([__int64], [AC_CHECK_SIZEOF(__int64)])
+AC_TYPE_UINT64_T
+if test x"$ac_cv_c_uint64_t" = x"no"; then
+ AC_MSG_ERROR([uint64_t not found])
+fi
AC_STRUCT_TM
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)