summaryrefslogtreecommitdiff
path: root/libffi/Makefile.am
diff options
context:
space:
mode:
authorAndrew Haley <aph@redhat.com>2009-06-09 10:21:19 +0000
committerAndrew Haley <aph@gcc.gnu.org>2009-06-09 10:21:19 +0000
commitb7b857bbe2dbbafe570afb767efc1fff9e6b8861 (patch)
tree52255ff30684d11d27a4d9a528272b9dd3072e2b /libffi/Makefile.am
parent3dbbb7af5b4dd3ae01a9347081f4b486d3752160 (diff)
downloadgcc-b7b857bbe2dbbafe570afb767efc1fff9e6b8861.tar.gz
Import from libffi 3.0.8:
2009-06-08 Andrew Haley <aph@redhat.com> Import from libffi 3.0.8: * doc/libffi.texi: New file. * doc/libffi.info: Likewise. * doc/stamp-vti: Likewise. * man/Makefile.am: New file. * man/ffi_call.3: New file. * Makefile.am (EXTRA_DIST): Add src/x86/darwin64.S, src/dlmalloc.c. (nodist_libffi_la_SOURCES): Add X86_FREEBSD. * configure.ac: Bump version to 3.0.8. parisc*-*-linux*: Add. i386-*-freebsd* | i386-*-openbsd*: Add. powerpc-*-beos*: Add. AM_CONDITIONAL X86_FREEBSD: Add. AC_CONFIG_FILES: Add man/Makefile. * include/ffi.h.in (FFI_FN): Change void (*)() to void (*)(void). From-SVN: r148309
Diffstat (limited to 'libffi/Makefile.am')
-rw-r--r--libffi/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/libffi/Makefile.am b/libffi/Makefile.am
index 6bc8c1b0ea3..775961353dd 100644
--- a/libffi/Makefile.am
+++ b/libffi/Makefile.am
@@ -3,7 +3,7 @@
AUTOMAKE_OPTIONS = foreign subdir-objects
ACLOCAL_AMFLAGS = -I .. -I ../config
-SUBDIRS = include testsuite
+SUBDIRS = include testsuite man
EXTRA_DIST = LICENSE ChangeLog.v1 ChangeLog.libgcj configure.host \
src/alpha/ffi.c src/alpha/osf.S src/alpha/ffitarget.h \
@@ -25,11 +25,13 @@ EXTRA_DIST = LICENSE ChangeLog.v1 ChangeLog.libgcj configure.host \
src/sh/ffi.c src/sh/sysv.S src/sh/ffitarget.h \
src/sh64/ffi.c src/sh64/sysv.S src/sh64/ffitarget.h \
src/sparc/v8.S src/sparc/v9.S src/sparc/ffitarget.h \
- src/sparc/ffi.c \
+ src/sparc/ffi.c src/x86/darwin64.S \
src/x86/ffi.c src/x86/sysv.S src/x86/win32.S src/x86/darwin.S \
src/x86/ffi64.c src/x86/unix64.S src/x86/ffitarget.h \
src/pa/ffitarget.h src/pa/ffi.c src/pa/linux.S src/pa/hpux32.S \
- src/frv/ffi.c src/frv/eabi.S src/frv/ffitarget.h
+ src/frv/ffi.c src/frv/eabi.S src/frv/ffitarget.h src/dlmalloc.c
+
+info_TEXINFOS = doc/libffi.texi
## ################################################################
@@ -90,6 +92,9 @@ endif
if X86
nodist_libffi_la_SOURCES += src/x86/ffi.c src/x86/sysv.S
endif
+if X86_FREEBSD
+nodist_libffi_la_SOURCES += src/x86/ffi.c src/x86/freebsd.S
+endif
if X86_WIN32
nodist_libffi_la_SOURCES += src/x86/ffi.c src/x86/win32.S
endif