summaryrefslogtreecommitdiff
path: root/libffi/Makefile.am
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2016-03-03 13:40:30 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2016-03-03 13:40:30 +0000
commit8f57374be53289200a950dad2029660194aee049 (patch)
tree3132d1b13c80c00c71a97562cc42db1da97078f7 /libffi/Makefile.am
parent1bc579edc7f44642c2f503556db9c5a46e4e8a87 (diff)
downloadgcc-8f57374be53289200a950dad2029660194aee049.tar.gz
Fix passing object names to make_sunver.pl
* Makefile.am (libffi.map-sun): Properly convert $(libffi_la_OBJECTS) to object names. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@233938 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/Makefile.am')
-rw-r--r--libffi/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/libffi/Makefile.am b/libffi/Makefile.am
index 159b6e81a73..dc433285362 100644
--- a/libffi/Makefile.am
+++ b/libffi/Makefile.am
@@ -215,8 +215,7 @@ libffi_version_dep = libffi.map-sun
libffi.map-sun : libffi.map $(top_srcdir)/../contrib/make_sunver.pl \
$(libffi_la_OBJECTS) $(libffi_la_LIBADD)
perl $(top_srcdir)/../contrib/make_sunver.pl libffi.map \
- $(libffi_la_OBJECTS:%.lo=.libs/%.o) \
- `echo $(libffi_la_LIBADD) | \
+ `echo $(libffi_la_OBJECTS) $(libffi_la_LIBADD) | \
sed 's,\([^/ ]*\)\.l\([ao]\),.libs/\1.\2,g'` \
> $@ || (rm -f $@ ; exit 1)
endif