summaryrefslogtreecommitdiff
path: root/libgcc/configure.ac
diff options
context:
space:
mode:
authormeissner <meissner@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-24 17:04:47 +0000
committermeissner <meissner@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-24 17:04:47 +0000
commit10de71e103272ab95d389659e312b95e6b86a65c (patch)
treeec50c8ab7786788a6da7d4f06b0cd93e9555d487 /libgcc/configure.ac
parent99ad623febd84d2a9cf4c2d0ad950c48c650a624 (diff)
downloadgcc-10de71e103272ab95d389659e312b95e6b86a65c.tar.gz
Add BID decimal support
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@123185 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgcc/configure.ac')
-rw-r--r--libgcc/configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/libgcc/configure.ac b/libgcc/configure.ac
index 825805d7c6d..2e95e31e390 100644
--- a/libgcc/configure.ac
+++ b/libgcc/configure.ac
@@ -107,6 +107,42 @@ AC_CACHE_CHECK([whether decimal floating point is supported], [libgcc_cv_dfp],
decimal_float=$libgcc_cv_dfp
AC_SUBST(decimal_float)
+AC_ARG_ENABLE(decimal-float,
+[ --enable-decimal-float={no,yes,bid,dpd}
+ enable decimal float extension to C. Selecting 'bid'
+ or 'dpd' choses which decimal floating point format
+ to use],
+[
+ case $enable_decimal_float in
+ yes | no | bid | dpd) ;;
+ *) AC_MSG_ERROR(['$enable_decimal_float' is an invalid value for --enable-decimal-float.
+Valid choices are 'yes', 'bid', 'dpd', and 'no'.]) ;;
+ esac
+],
+[
+ case $target in
+ powerpc*-*-linux* | i?86*-*-linux* | x86_64*-*-linux*)
+ enable_decimal_float=yes
+ ;;
+ *)
+ enable_decimal_float=no
+ ;;
+ esac
+])
+
+# x86's use BID format instead of DPD
+if test x$enable_decimal_float = xyes; then
+ case $target in
+ i?86*-*-linux* | x86_64*-*-linux*)
+ enable_decimal_float=bid
+ ;;
+ *)
+ enable_decimal_float=dpd
+ ;;
+ esac
+fi
+AC_SUBST(enable_decimal_float)
+
# Collect host-machine-specific information.
. ${srcdir}/config.host