summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorjb <jb@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-02 08:48:24 +0000
committerjb <jb@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-02 08:48:24 +0000
commit290423f02f2ce377262b21816ed9ebdd3cc070a5 (patch)
tree74e43d0af93ad7827a8164bfa3ba1469d9f6c579 /libgfortran/configure.ac
parent619349e675cbe91bb45b3c41b87323a691d32514 (diff)
downloadgcc-290423f02f2ce377262b21816ed9ebdd3cc070a5.tar.gz
PR 47571 Weakref trickery for clock_gettime()
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@169517 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index ed1e2cc31a1..816165988ce 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -486,11 +486,11 @@ AC_CHECK_LIB([m],[feenableexcept],[have_feenableexcept=yes AC_DEFINE([HAVE_FEENA
# At least for glibc, clock_gettime is in librt. But don't pull that
# in if it still doesn't give us the function we want.
-# This test is copied from libgomp.
+# This test is copied from libgomp, and modified to not link in -lrt
+# as libgfortran calls clock_gettime via a weak reference.
if test $ac_cv_func_clock_gettime = no; then
AC_CHECK_LIB(rt, clock_gettime,
- [LIBS="-lrt $LIBS"
- AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
+ [AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
[Define to 1 if you have the `clock_gettime' function.])])
fi