summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorburnus <burnus@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-21 16:16:10 +0000
committerburnus <burnus@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-21 16:16:10 +0000
commite93cd3187c29f422d142eaa6de64175ae89efbee (patch)
treea99bf5364c681de7075f0f28f1287cd4ae87d259 /libgfortran/configure.ac
parent533a9fbc2542e52b8366dda8158b1d7ec7ee49bd (diff)
downloadgcc-e93cd3187c29f422d142eaa6de64175ae89efbee.tar.gz
2006-12-09 Tobias Burnus <burnus@net-b.de>
PR libfortran/30015 * intrinsics/date_and_time.c (date_and_time): Fix case where time can go backwards. * configure.ac: Remove AC_TRY_RUN test for timezone in gettimeofday. * acinclude.m4: Ditto. * configure: Regenerate. * config.h.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@121033 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 802d5ad3e08..8711134d480 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -160,6 +160,7 @@ AC_TYPE_OFF_T
# check header files
AC_STDC_HEADERS
+AC_HEADER_TIME
AC_HAVE_HEADERS(stdlib.h stdio.h string.h stddef.h math.h unistd.h signal.h)
AC_CHECK_HEADERS(time.h sys/params.h sys/time.h sys/times.h sys/resource.h)
AC_CHECK_HEADERS(sys/types.h sys/stat.h sys/wait.h floatingpoint.h ieeefp.h)
@@ -175,7 +176,7 @@ AC_CHECK_MEMBERS([struct stat.st_rdev])
AC_CHECK_FUNCS(getrusage times mkstemp strtof strtold snprintf ftruncate chsize)
AC_CHECK_FUNCS(chdir strerror getlogin gethostname kill link symlink perror)
AC_CHECK_FUNCS(sleep time ttyname signal alarm ctime clock access fork execl)
-AC_CHECK_FUNCS(wait setmode getrlimit)
+AC_CHECK_FUNCS(wait setmode getrlimit gettimeofday)
# Check for types
AC_CHECK_TYPES([intptr_t])
@@ -377,11 +378,6 @@ AC_MSG_NOTICE([FPU dependent file will be ${fpu_host}.h])
FPU_HOST_HEADER=config/${fpu_host}.h
AC_SUBST(FPU_HOST_HEADER)
-# The standard autoconf HAVE_STRUCT_TIMEZONE doesn't actually check
-# for struct timezone, as you might think. We also need to check how
-# to call gettimeofday if we have it.
-LIBGFOR_GETTIMEOFDAY
-
# Attempt to assert that the target is of common type in case we don't
# have C99 integer types at all.
LIBGFOR_TARGET_ILP32