summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2005-11-05 21:09:13 +0000
committerrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2005-11-05 21:09:13 +0000
commitd1191d66c696498fbcc1d1c598e1a3736d8142f3 (patch)
treee29c743b82f2f1ee1e278acb8b57aa446a4856b4 /libgfortran/configure.ac
parent942043f8b1e9c4040e632488ea345801b2f670a9 (diff)
downloadgcc-d1191d66c696498fbcc1d1c598e1a3736d8142f3.tar.gz
2005-11-05 Richard Guenther <rguenther@suse.de>
* configure.ac: Use AM_FCFLAGS for extra flags, not FCFLAGS. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@106535 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 1808455acad..6ca4565e024 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -109,9 +109,9 @@ m4_define([_AC_ARG_VAR_PRECIOUS],[])
AC_PROG_CC
m4_rename([real_PRECIOUS],[_AC_ARG_VAR_PRECIOUS])
-# Add -Wall if we are using GCC.
+# Add -Wall -fno-repack-arrays -fno-underscoring if we are using GCC.
if test "x$GCC" = "xyes"; then
- AM_FCFLAGS="-Wall"
+ AM_FCFLAGS="-Wall -fno-repack-arrays -fno-underscoring"
## We like to use C99 routines when available. This makes sure that
## __STDC_VERSION__ is set such that libc includes make them available.
AM_CFLAGS="-std=gnu99 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wextra -Wwrite-strings"
@@ -135,11 +135,9 @@ AC_SUBST(enable_static)
#AC_MSG_NOTICE([====== Finished libtool configuration]) ; sleep 10
# We need gfortran to compile parts of the library
-# We can't use AC_PROG_FC because it expects a fully working gfortran.
#AC_PROG_FC(gfortran)
FC="$GFORTRAN"
AC_PROG_FC(gfortran)
-FCFLAGS="$FCFLAGS -Wall -fno-repack-arrays -fno-underscoring"
# extra LD Flags which are required for targets
case "${host}" in