summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2012-02-08 19:38:17 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2012-02-08 19:38:17 +0000
commit68e1881d7403f946c72275220d8e6b089c6701b9 (patch)
treea1a0850efce956decdd30ccf8cc67d64ab875d26 /libgo/Makefile.am
parent72851b689c79d92cf20066ff706cfc5e06392e67 (diff)
downloadgcc-68e1881d7403f946c72275220d8e6b089c6701b9.tar.gz
math: Compile with -mfancy-math-387 -funsafe-optimizations on x86.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@184015 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 3f5bb2ff5b2..b94bc06ac3b 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -1959,7 +1959,9 @@ log/check: $(CHECK_DEPS)
math/math.lo.dep: $(go_math_files)
$(BUILDDEPS)
math/math.lo: $(go_math_files)
- $(BUILDPACKAGE)
+ $(MKDIR_P) $(@D)
+ files=`echo $^ | sed -e 's/[^ ]*\.gox//g'`; \
+ $(LTGOCOMPILE) $(MATH_FLAG) -I . -c -fgo-prefix="libgo_$(@D)" -o $@ $$files
math/check: $(CHECK_DEPS)
@$(CHECK)
.PHONY: math/check