summaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-01-14 19:18:38 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-01-14 19:18:38 +0000
commit554126c9d99ed74db00501555b33513f54c66c39 (patch)
treeb06d52ec11eb4a047cce6d629203450c13c1d9c3 /libgo/configure.ac
parente11609d3c3bcc349f65cfe7789b0e243f3c3d32d (diff)
downloadgcc-554126c9d99ed74db00501555b33513f54c66c39.tar.gz
libgo: Check whether we need -lrt for sched_yield.
From Rainer Orth. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@168816 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index 7d348dcf803..3d272ec8d60 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -274,6 +274,9 @@ PTHREAD_LIBS=
AC_CHECK_LIB([pthread], [pthread_create], PTHREAD_LIBS=-lpthread)
AC_SUBST(PTHREAD_LIBS)
+dnl Test if -lrt is required for sched_yield.
+AC_SEARCH_LIBS([sched_yield], [rt])
+
AC_C_BIGENDIAN
GCC_CHECK_UNWIND_GETIPINFO