summaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-04-25 19:36:12 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-04-25 19:36:12 +0000
commite0519e0586e490e64776a9a0e51cfca5e1e6540a (patch)
tree8c44faa207647f4f8db0f245add06c9ed21e26f5 /libgo/configure.ac
parentcdd0bb4bde4f6885045e65860de0320ccf6b23f6 (diff)
downloadgcc-e0519e0586e490e64776a9a0e51cfca5e1e6540a.tar.gz
libgo: Irix 6 patches.
From Rainer Orth. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@172935 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index e772c2a12de..2451214f768 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -140,7 +140,7 @@ is_386=no
is_alpha=no
is_arm=no
is_m68k=no
-mips_abi=""
+mips_abi=unknown
is_ppc=no
is_ppc64=no
is_sparc=no
@@ -233,7 +233,7 @@ AM_CONDITIONAL(LIBGO_IS_386, test $is_386 = yes)
AM_CONDITIONAL(LIBGO_IS_ALPHA, test $is_alpha = yes)
AM_CONDITIONAL(LIBGO_IS_ARM, test $is_arm = yes)
AM_CONDITIONAL(LIBGO_IS_M68K, test $is_m68k = yes)
-AM_CONDITIONAL(LIBGO_IS_MIPS, test $mips_abi != "")
+AM_CONDITIONAL(LIBGO_IS_MIPS, test $mips_abi != unknown)
AM_CONDITIONAL(LIBGO_IS_MIPSO32, test $mips_abi = o32)
AM_CONDITIONAL(LIBGO_IS_MIPSN32, test $mips_abi = n32)
AM_CONDITIONAL(LIBGO_IS_MIPSN64, test $mips_abi = n64)
@@ -260,6 +260,11 @@ AC_SUBST(GO_DEBUG_PROC_REGS_OS_ARCH_FILE)
dnl Some targets need special flags to build sysinfo.go.
case "$target" in
+ mips-sgi-irix6.5*)
+ # IRIX 6 needs _XOPEN_SOURCE=500 for the XPG5 version of struct
+ # msghdr in <sys/socket.h>.
+ OSCFLAGS='-D_XOPEN_SOURCE=500'
+ ;;
*-*-solaris2.[[89]])
# Solaris 8/9 need this so struct msghdr gets the msg_control
# etc. fields in <sys/socket.h> (_XPG4_2).