summaryrefslogtreecommitdiff
path: root/libgomp/Makefile.am
diff options
context:
space:
mode:
authorjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2006-02-15 07:46:39 +0000
committerjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2006-02-15 07:46:39 +0000
commitebe48f5e2c13dc4bc7ca1a3dddb723da74a7830e (patch)
treede43e2887704ae8b3ec08a0cb5c51194fc73b422 /libgomp/Makefile.am
parentc31af58500d7efc6903f776ab022ce4dc2d560a1 (diff)
downloadgcc-ebe48f5e2c13dc4bc7ca1a3dddb723da74a7830e.tar.gz
PR libgomp/25938
PR libgomp/25984 fortran/ * Make-lang.in (install-finclude-dir): New goal. (fortran.install-common): Depend on install-finclude-dir. * lang-specs.h: If not -nostdinc, add -I finclude. libgomp/ * Makefile.am (fincludedir): New variable. (nodist_include_HEADERS): Remove Fortran files. (nodist_finclude_HEADERS): New variable. * Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@111018 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgomp/Makefile.am')
-rw-r--r--libgomp/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libgomp/Makefile.am b/libgomp/Makefile.am
index 55f93730375..e4c5389e62d 100644
--- a/libgomp/Makefile.am
+++ b/libgomp/Makefile.am
@@ -9,6 +9,8 @@ gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
config_path = @config_path@
search_path = $(addprefix $(top_srcdir)/config/, $(config_path)) $(top_srcdir)
+fincludedir = $(libdir)/gcc/$(target_alias)/$(gcc_version)/finclude
+
empty =
space = $(empty) $(empty)
VPATH = $(subst $(space),:,$(strip $(search_path)))
@@ -33,9 +35,9 @@ libgomp_la_SOURCES = alloc.c barrier.c critical.c env.c error.c iter.c \
lock.c mutex.c proc.c sem.c bar.c time.c fortran.c
nodist_noinst_HEADERS = libgomp_f.h
-nodist_include_HEADERS = omp.h omp_lib.h omp_lib.f90
+nodist_include_HEADERS = omp.h
if USE_FORTRAN
-nodist_include_HEADERS += omp_lib.mod omp_lib_kinds.mod
+nodist_finclude_HEADERS = omp_lib.h omp_lib.f90 omp_lib.mod omp_lib_kinds.mod
endif
omp_lib_kinds.mod: omp_lib.mod