summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2011-07-22 08:33:37 +0000
committerjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2011-07-22 08:33:37 +0000
commit00dacc40f84ec2a9c964f8addfb09ce6946c4a5a (patch)
tree2bd70c0d114f37575687da7d0ce9ef17bc9cbcc3 /libiberty/configure.ac
parent621bdf5df65da3c8ae7851090ed3d8611442900b (diff)
downloadgcc-00dacc40f84ec2a9c964f8addfb09ce6946c4a5a.tar.gz
PR c++/49756
* libiberty.h (stack_limit_increase): New prototype. * stack-limit.c: New file. * Makefile.in: Regenerate deps. (CFILES): Add stack-limit.c. (REQUIRED_OFILES): Add ./stack-limit.$(objext). * configure.ac (checkfuncs): Add getrlimit and setrlimit. (AC_CHECK_FUNCS): Likewise. * configure: Regenerated. * config.in: Regenerated. * gcc.c (main): Call stack_limit_increase (64MB). * toplev.c (toplev_main): Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@176617 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index 9f1ff04938e..eebd7e99105 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -358,10 +358,10 @@ funcs="$funcs setproctitle"
vars="sys_errlist sys_nerr sys_siglist"
-checkfuncs="__fsetlocking canonicalize_file_name dup3 getrusage getsysinfo \
- gettimeofday on_exit psignal pstat_getdynamic pstat_getstatic realpath \
- sbrk spawnve spawnvpe strerror strsignal sysconf sysctl sysmp table \
- times wait3 wait4"
+checkfuncs="__fsetlocking canonicalize_file_name dup3 getrlimit getrusage \
+ getsysinfo gettimeofday on_exit psignal pstat_getdynamic pstat_getstatic \
+ realpath setrlimit sbrk spawnve spawnvpe strerror strsignal sysconf sysctl \
+ sysmp table times wait3 wait4"
# These are neither executed nor required, but they help keep
# autoheader happy without adding a bunch of text to acconfig.h.
@@ -371,13 +371,13 @@ if test "x" = "y"; then
calloc canonicalize_file_name clock \
dup3 \
ffs __fsetlocking \
- getcwd getpagesize getrusage getsysinfo gettimeofday \
+ getcwd getpagesize getrlimit getrusage getsysinfo gettimeofday \
index insque \
memchr memcmp memcpy memmem memmove memset mkstemps \
on_exit \
psignal pstat_getdynamic pstat_getstatic putenv \
random realpath rename rindex \
- sbrk setenv setproctitle sigsetmask snprintf spawnve spawnvpe \
+ sbrk setenv setproctitle setrlimit sigsetmask snprintf spawnve spawnvpe \
stpcpy stpncpy strcasecmp strchr strdup \
strerror strncasecmp strndup strrchr strsignal strstr strtod strtol \
strtoul strverscmp sysconf sysctl sysmp \