summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2014-04-17 12:25:25 +0000
committerjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2014-04-17 12:25:25 +0000
commitf945635a3df2255e39e20d3b696520de808c5759 (patch)
tree47cfcc6b2ff22d34b1cb69c133eaa143f2c4117d /libiberty/configure.ac
parent478532eb6ce5146124ce550550d3c903c95bc497 (diff)
downloadgcc-f945635a3df2255e39e20d3b696520de808c5759.tar.gz
PR sanitizer/56781
lto-plugin/ * Makefile.am (CFLAGS, LDFLAGS): Filter out -fsanitize=address. (liblto_plugin_la_LIBADD, liblto_plugin_la_LDFLAGS, liblto_plugin_la_DEPENDENCIES): Prefer ../libiberty/noasan/libiberty.a over ../libiberty/pic/libiberty.a if the former exists. * Makefile.in: Regenerated. libiberty/ * maint-tool: Also emit rule for noasan/ subdirectory. * configure.ac (NOASANFLAG): Set and substitute. * Makefile.in: Regenerated. (NOASANFLAG): Set. (all, $(TARGETLIB), mostlyclean): Handle noasan subdir like pic subdir. (stamp-noasandir): New goal. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@209476 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index d6180bcddd9..3380819ab3a 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -236,6 +236,12 @@ if [[ "${shared}" != "yes" ]]; then
fi
AC_SUBST(PICFLAG)
+NOASANFLAG=
+case " ${CFLAGS} " in
+ *\ -fsanitize=address\ *) NOASANFLAG=-fno-sanitize=address ;;
+esac
+AC_SUBST(NOASANFLAG)
+
echo "# Warning: this fragment is automatically generated" > temp-frag
if [[ -n "${frag}" ]] && [[ -f "${frag}" ]]; then