summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>1998-11-13 16:36:04 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>1998-11-13 16:36:04 +0000
commit34fa88316071e4f2d3aab04444bbaa996495499c (patch)
tree3ba8d1fed8bcc7504da2c11d5b6e63f2bdf140e3 /libiberty/configure.in
parent28e7433da246f2a1bcf2f555bac47fb7106662de (diff)
downloadgcc-34fa88316071e4f2d3aab04444bbaa996495499c.tar.gz
* configure.in: Check for calloc.
* calloc.c: New file. * xmalloc.c (xcalloc): New function. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@23642 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index ee824595cdc..78bf96093e9 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -117,6 +117,7 @@ funcs="$funcs basename"
funcs="$funcs bcmp"
funcs="$funcs bcopy"
funcs="$funcs bzero"
+funcs="$funcs calloc"
funcs="$funcs clock"
funcs="$funcs getcwd"
funcs="$funcs getpagesize"
@@ -156,7 +157,7 @@ checkfuncs="getrusage on_exit psignal strerror strsignal sysconf times"
# These are neither executed nor required, but they help keep
# autoheader happy without adding a bunch of text to acconfig.h.
if test "x" = "y"; then
- AC_CHECK_FUNCS(asprintf atexit basename bcmp bcopy bzero clock getcwd)
+ AC_CHECK_FUNCS(asprintf atexit basename bcmp bcopy bzero calloc clock getcwd)
AC_CHECK_FUNCS(getpagesize index insque memchr memcmp memcpy memmove)
AC_CHECK_FUNCS(memset random rename rindex sigsetmask strcasecmp)
AC_CHECK_FUNCS(strchr strdup strncasecmp strrchr strstr strtod strtol)