summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2003-02-21 20:33:50 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2003-02-21 20:33:50 +0000
commit622d92fb75601a7635181acdeb068b83cb6ba515 (patch)
tree6c552af30d13caf2270655116cccc34ae08607c6 /libiberty/configure.in
parent6914c51f8feb89890d293072e20813446c18c4d9 (diff)
downloadgcc-622d92fb75601a7635181acdeb068b83cb6ba515.tar.gz
* physmem.c (physmem_total) [HAVE_GETSYSINFO]: Use getsysinfo on
Tru64 UNIX. (physmem_available) [HAVE_TABLE && HAVE_SYS_TABLE_H]: Use table on Tru64 UNIX. * configure.in (AC_CHECK_HEADERS): Check for sys/sysinfo.h, machine/hal_sysinfo.h, sys/table.h. (checkfuncs, AC_CHECKFUNCS): Check for getsysinfo, table. * configure, config.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@63241 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index ead53b421eb..3b842fcd687 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -142,7 +142,7 @@ AC_SUBST_FILE(host_makefile_frag)
# It's OK to check for header files. Although the compiler may not be
# able to link anything, it had better be able to at least compile
# something.
-AC_CHECK_HEADERS(sys/file.h sys/param.h limits.h stdlib.h string.h unistd.h strings.h sys/time.h time.h sys/resource.h sys/stat.h sys/mman.h fcntl.h alloca.h sys/pstat.h sys/sysmp.h)
+AC_CHECK_HEADERS(sys/file.h sys/param.h limits.h stdlib.h string.h unistd.h strings.h sys/time.h time.h sys/resource.h sys/stat.h sys/mman.h fcntl.h alloca.h sys/pstat.h sys/sysmp.h sys/sysinfo.h machine/hal_sysinfo.h sys/table.h)
AC_HEADER_SYS_WAIT
AC_HEADER_TIME
@@ -208,6 +208,7 @@ vars="sys_errlist sys_nerr sys_siglist"
checkfuncs="getrusage on_exit psignal strerror strsignal sysconf times sbrk gettimeofday"
checkfuncs="$checkfuncs realpath canonicalize_file_name pstat_getstatic pstat_getdynamic sysmp"
+checkfuncs="$checkfuncs getsysinfo table"
# These are neither executed nor required, but they help keep
# autoheader happy without adding a bunch of text to acconfig.h.
@@ -219,7 +220,7 @@ if test "x" = "y"; then
AC_CHECK_FUNCS(strtod strtol strtoul tmpnam vasprintf vfprintf vprintf)
AC_CHECK_FUNCS(vsprintf waitpid getrusage on_exit psignal strerror strsignal)
AC_CHECK_FUNCS(sysconf times sbrk gettimeofday ffs)
- AC_CHECK_FUNCS(pstat_getstatic pstat_getdynamic sysmp)
+ AC_CHECK_FUNCS(pstat_getstatic pstat_getdynamic sysmp getsysinfo table)
AC_CHECK_FUNCS(realpath canonicalize_file_name)
AC_DEFINE(HAVE_SYS_ERRLIST, 1, [Define if you have the sys_errlist variable.])
AC_DEFINE(HAVE_SYS_NERR, 1, [Define if you have the sys_nerr variable.])