summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>2001-11-15 18:11:24 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>2001-11-15 18:11:24 +0000
commit7b190504bdf285383c0987485896525d09057470 (patch)
tree3ec44408c0caf6a35fc908c7b6a6e08021a49721 /libiberty/configure.in
parente9fb7b395e10a11f9f7cd40ef76d205ac36df823 (diff)
downloadgcc-7b190504bdf285383c0987485896525d09057470.tar.gz
* config.in (HAVE_UINTPTR_T): Provide autoconf stub.
* configure.in (HAVE_UINTPTR_T): Test for system defining uintptr_t and define HAVE_UINTPTR_T appropriately. * regex.c (uintptr_t): Do not provide a definition if the system provided one. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@47068 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index 505b520ba87..7fc4856e606 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -126,6 +126,18 @@ AC_HEADER_TIME
libiberty_AC_DECLARE_ERRNO
+AC_MSG_CHECKING(for uintptr_t)
+AC_EGREP_HEADER(uintptr_t, sys/types.h,
+ libiberty_cv_uintptr_t=yes, libiberty_cv_uintptr_t=no)
+
+if test $libiberty_cv_uintptr_t = yes
+then
+ AC_DEFINE(HAVE_UINTPTR_T)
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
# This is the list of functions which libiberty will provide if they
# are not available on the host.