summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-26 00:40:51 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-26 00:40:51 +0000
commitdde96550e82d0fdb11507233f4bae19ddb39c8cd (patch)
tree14ec38e32af7c78c7fdd8b489305ec0f717c4bec /libiberty/configure.in
parentad7c5e37517c3cf2a11649e886b998eb426fb5ca (diff)
downloadgcc-dde96550e82d0fdb11507233f4bae19ddb39c8cd.tar.gz
* configure.in (alloca detection): Handle alloca directly for interix.
* configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26635 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index da33ca9487b..77eec3bf43e 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -299,7 +299,28 @@ if test -z "${setobjs}"; then
# tests. This will only work if the compiler works.
AC_PROG_CC_WORKS
AC_REPLACE_FUNCS($funcs)
- AC_FUNC_ALLOCA
+
+ case "${host}" in
+ *-*-interix)
+ # On Interix, it wrongly concludes that the MSVC compiler supports alloca.
+ # (MSVC does on Win32, not on Interix.)
+ # This should be temporary.
+
+ ac_cv_header_alloca_h=no
+ ac_cv_func_alloca_works=no
+ ALLOCA=alloca.o
+ cat >> confdefs.h <<\EOF
+#define C_ALLOCA 1
+EOF
+ cat >> confdefs.h <<EOF
+#define STACK_DIRECTION -1
+EOF
+ ;;
+ *)
+ AC_FUNC_ALLOCA
+ ;;
+ esac
+
AC_FUNC_VFORK
if test $ac_cv_func_vfork_works = no; then
LIBOBJS="$LIBOBJS vfork.o"