summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-02-09 00:17:32 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-02-09 00:17:32 +0000
commit301e59c9a8d2634fd35ef076c98041b6d9cf44f6 (patch)
treec79267a720dfb5f56f9df94cdad44ee4ce7f7962 /libiberty/configure.in
parent5f3760f6055c6ed88714eb85d98eb32382619990 (diff)
downloadgcc-301e59c9a8d2634fd35ef076c98041b6d9cf44f6.tar.gz
* Makefile.in (REQUIRED_OFILES): remove mkstemp.o
* configure.in (funcs): Check for and conditionally add mkstemps to the list of functions libiberty will provide. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@25106 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index a189b0794cb..9cc651c43fa 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -129,6 +129,7 @@ funcs="$funcs memcmp"
funcs="$funcs memcpy"
funcs="$funcs memmove"
funcs="$funcs memset"
+funcs="$funcs mkstemps"
funcs="$funcs random"
funcs="$funcs rename"
funcs="$funcs rindex"
@@ -159,7 +160,7 @@ checkfuncs="getrusage on_exit psignal strerror strsignal sysconf times"
# autoheader happy without adding a bunch of text to acconfig.h.
if test "x" = "y"; then
AC_CHECK_FUNCS(asprintf atexit basename bcmp bcopy bzero calloc clock getcwd)
- AC_CHECK_FUNCS(getpagesize index insque memchr memcmp memcpy memmove)
+ AC_CHECK_FUNCS(getpagesize index insque mkstemps memchr memcmp memcpy memmove)
AC_CHECK_FUNCS(memset random rename rindex sigsetmask strcasecmp)
AC_CHECK_FUNCS(strchr strdup strncasecmp strrchr strstr strtod strtol)
AC_CHECK_FUNCS(strtoul tmpnam vasprintf vfprintf vprintf vsprintf waitpid)