summaryrefslogtreecommitdiff
path: root/libio/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1997-09-16 16:01:55 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1997-09-16 16:01:55 +0000
commita6bb47e073377fa203132a3ae20f76103a8049b7 (patch)
tree6f133200943f818cad1e94da16393eadfe8dd250 /libio/configure.in
parentdb3b49b1fef1f3ba83eeb6537963bd7884e89602 (diff)
downloadgcc-a6bb47e073377fa203132a3ae20f76103a8049b7.tar.gz
Uli's libio/libstdc++ patches.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@15486 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libio/configure.in')
-rw-r--r--libio/configure.in27
1 files changed, 25 insertions, 2 deletions
diff --git a/libio/configure.in b/libio/configure.in
index b14c3b17215..06c6fdabea5 100644
--- a/libio/configure.in
+++ b/libio/configure.in
@@ -16,12 +16,13 @@ frags=
case "${target}" in
*-hpux*) frags=hpux.mt ;;
- *-linux*)
+ *-linux-gnulibc1)
echo "WARNING: The I/O implementation in FSF libg++ 2.8.x is not"
echo " compatible with Linux libc through 5.2.x."
echo " See libg++/README for more information."
echo " YOU ARE ON YOUR OWN!"
- frags=linux.mt ;;
+ frags=linuxlibc1.mt ;;
+ *-linux-gnu) frags=linux.mt ;;
*-sco3.2v[45]*) frags=sco4.mt ;;
*-isc*) frags=isc.mt ;;
*-netware*) frags=netware.mt ;;
@@ -43,6 +44,28 @@ if [ "${shared}" = "yes" ]; then
esac
fi
+# Make a link for the correct stdio-lock.h file.
+case "${target}" in
+ *-linux-gnu)
+ # We have a correct file in glibc but the libioP.h file is written
+ # with glibc 2.1 in mind which has the internals headers in special
+ # directory while glibc 2.0 has them in /usr/include. Create a wrapper
+ # if necessary.
+ (echo "#include <bits/libc-lock.h>" | ${CC-cc} -E -) >/dev/null 2>&1 ||
+ {
+ rm -fr bits
+ mkdir bits
+ echo "#include <libc-lock.h>" > bits/libc-lock.h
+ echo "#include <stdio-lock.h>" > bits/stdio-lock.h
+ }
+ ;;
+ *)
+ rm -fr bits
+ mkdir bits
+ ln -s ${srcdir}/include/empty.h bits/stdio-lock.h
+ ;;
+esac
+
for frag in ${frags}; do
frag=${srcdir}/config/$frag
if [ -f ${frag} ]; then