summaryrefslogtreecommitdiff
path: root/libio/configure.in
diff options
context:
space:
mode:
authorjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-12 08:39:23 +0000
committerjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-12 08:39:23 +0000
commit51f9897c2ceb3ff0aa5f1c1c719bad5e55046d92 (patch)
tree57611b2cd9bfed4be5ac8216aee8c05f76c03fa5 /libio/configure.in
parent09b00b9e0596b5e82ba396a0eef544a2555826e4 (diff)
downloadgcc-51f9897c2ceb3ff0aa5f1c1c719bad5e55046d92.tar.gz
* configure.in (compiler_name): Don't do the skip-this-dir thing
if we're reconfiguring. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26899 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libio/configure.in')
-rw-r--r--libio/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/libio/configure.in b/libio/configure.in
index b2568e5a6be..084e901aabf 100644
--- a/libio/configure.in
+++ b/libio/configure.in
@@ -18,9 +18,11 @@ esac
# does, we do not build anything. Note, $r is set by the top-level Makefile.
# Note that when we look for the compiler, we search both with and without
# extension to handle cross and canadian cross builds.
+# Note that if $norecursion is set we're being called from config.status,
+# so don't check for the compiler; we might be doing a make clean.
compiler_name=cc1plus
rm -f skip-this-dir
-if test -n "$r"; then
+if test -n "$r" && [ -z "$norecursion" ] ; then
if test -d "$r"/gcc; then
if test -f "$r"/gcc/$compiler_name \
|| test -f "$r"/gcc/$compiler_name$EXEEXT; then