summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorgreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2000-08-26 19:25:13 +0000
committergreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2000-08-26 19:25:13 +0000
commitac96e9f0c156bca8ecfd01792509e39aa6f3b7ff (patch)
treeec60dfe7b11606b3c5c1d32bb2b29e9dd37d5be1 /libjava/Makefile.am
parent69bb8d03035473dfec3a2c5d43738995a2b6c09e (diff)
downloadgcc-ac96e9f0c156bca8ecfd01792509e39aa6f3b7ff.tar.gz
2000-08-26 Anthony Green <green@redhat.com>
* Makefile.in: Rebuilt. * Makefile.am (java/lang/ClassLoader.h): Make _Jv_RunMain a friend. * prims.cc: Include ClassLoader.h. (_Jv_RunMain): When executing jar files, classpath must be the jar file only. Lose our reference to the system ClassLoader in order to get a new one with the correct classpath. * java/lang/natSystem.cc (init_properties): When executing a jar file, only use the jar file for java.class.path. * gnu/gcj/runtime/VMClassLoader.java: Use the canonical file name for bytecode archives. * gnu/gcj/runtime/FirstThread.java: Handle case where manifest exists, but not Main-Class. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@35999 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index ebf25e26561..7413f2696c2 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -225,6 +225,7 @@ $(nat_headers): libgcj.zip
java/lang/ClassLoader.h: java/lang/ClassLoader.class libgcj.zip
$(GCJH) -classpath $(top_builddir) \
-friend 'jclass _Jv_FindClass (_Jv_Utf8Const *name, java::lang::ClassLoader *loader);' \
+ -friend 'void _Jv_RunMain (const char *name, int argc, const char **argv, bool is_jar);' \
$(basename $<)
## Our internal main program needs to be able to create a FirstThread.